Bug 808777 - Almost all of the Non-geographic timezones in system-config-date result in incorrect time
Almost all of the Non-geographic timezones in system-config-date result in in...
Status: CLOSED DUPLICATE of bug 224442
Product: Fedora
Classification: Fedora
Component: tzdata (Show other bugs)
16
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Petr Machata
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-31 14:19 EDT by James
Modified: 2015-05-04 21:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-02 14:57:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James 2012-03-31 14:19:04 EDT
When using Non-geographic timezones in system-config-date, the resulting time is always off by 2 times the number timezones away from GMT. For instance, selecting GMT-5 should give Eastern Standard Time but instead gives Pakistan Standard Time, which is UTC+5.


system-config-date package version is 1.9.67


Steps to Reproduce:
Set timezone according to geographic location
Update clock using ntpdate
Observe correct time is set

Set timezone using GMT-5 for Eastern Standard Time.
Update clock using ntpdate
Observe time is off by +10 hours.
Comment 1 Nils Philippsen 2012-04-02 05:34:18 EDT
It seems that the non-geographic time zones are named counterintuitively.

This is what I got when setting the time zone to "GMT-2" and "GMT+5" which right now correspond to Central European Summer Time (DST) and Eastern Standard Time, respectively:

nils@gibraltar:~> date -R
Mon, 02 Apr 2012 11:13:05 +0200
nils@gibraltar:~> date
Mon Apr  2 11:13:09 GMT-2 2012

nils@gibraltar:~> date -R
Mon, 02 Apr 2012 04:14:01 -0500
nils@gibraltar:~> date
Mon Apr  2 04:14:02 GMT+5 2012

The names of the time zones are defined in tzdata, changing component accordingly.
Comment 2 Petr Machata 2012-04-02 14:57:08 EDT
Yes they are.  It's silly, I don't know what rationale there is for this, but apparently POSIX mandates this.

*** This bug has been marked as a duplicate of bug 224442 ***

Note You need to log in before you can comment on or make changes to this bug.