Bug 808778 - cloud-init sshutil fails with Fedora's default sshd_config
cloud-init sshutil fails with Fedora's default sshd_config
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cloud-init (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Garrett Holmstrom
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-31 15:18 EDT by Andy Grimm
Modified: 2016-11-07 22:46 EST (History)
2 users (show)

See Also:
Fixed In Version: cloud-init-0.6.3-0.2.bzr532.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-11 21:51:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
git-formatted patch (2.51 KB, patch)
2012-03-31 15:57 EDT, Andy Grimm
no flags Details | Diff

  None (edit)
Description Andy Grimm 2012-03-31 15:18:08 EDT
Description of problem:
cloud-init in F17 is failing to write ssh public keys into designated users' authorized_keys file when the default sshd_config is used in the AMI, due to incorrect interpretation of relative paths.

Version-Release number of selected component:
0.6.3-0.1.bzr532

Also filed upstream here:
https://bugs.launchpad.net/ubuntu/+source/cloud-init/+bug/970071
Comment 1 Andy Grimm 2012-03-31 15:57:45 EDT
Created attachment 574231 [details]
git-formatted patch

This patch should work... feel free to test.
Comment 2 Fedora Update System 2012-03-31 16:26:19 EDT
cloud-init-0.6.3-0.2.bzr532.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/cloud-init-0.6.3-0.2.bzr532.fc17
Comment 3 Fedora Update System 2012-04-01 13:34:57 EDT
Package cloud-init-0.6.3-0.2.bzr532.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cloud-init-0.6.3-0.2.bzr532.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5164/cloud-init-0.6.3-0.2.bzr532.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-04-11 21:51:46 EDT
cloud-init-0.6.3-0.2.bzr532.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.