Bug 808782 - Install corrupts partition
Install corrupts partition
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
i386 Linux
unspecified Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-31 16:49 EDT by Joe
Modified: 2013-02-13 09:01 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 09:01:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda.log (22.97 KB, text/plain)
2012-04-05 16:13 EDT, Joe
no flags Details
Anaconda.program.log (219.50 KB, text/plain)
2012-04-05 16:14 EDT, Joe
no flags Details
Anaconda.storage.log (751.67 KB, text/plain)
2012-04-05 16:15 EDT, Joe
no flags Details

  None (edit)
Description Joe 2012-03-31 16:49:57 EDT
Description of problem:
I had a hard drive with a windows partition, and an extended partition with two other partitions in it: a Linux distro (the OS calls it sda5), and some swapspace.
I had the Fedora installer resize the Linux distro and make a new PV in that space; it divded it into the Fedora root itself, and some more swapspace, and hooked that PV up to some volume group. I then had it delete the old swapspace, make a new PV in there, add it into the volume group, and use it to extend the Fedora root.
After the install, the sda5 partition can no longer be mounted.

Version-Release number of selected component (if applicable):
Fedora 16 installer (as included on the default Live CD)

How reproducible:
I've only tried once.

Steps to Reproduce:
1. Partition a disk in the following way:
/dev/sda:
 1 : NTFS (Windows)
 2 : Extended
     3 : ext4 (Some Linux Distro)
     4 : ext4 (A Boot partition)
     5 : swap
2. Have the Fedora installer repartition that as:
/dev/sda:
 1 : NTFS
 2 : Extended
     3 : ext4
     4 : about a half gigabyte of unallocated space. The installer refused to remove this
     5 : Part of volume group "vg_joesfedora"
     6 : ext4 (the Boot partition; this works fine)
     7 : Part of the volume group "vg_joesfedora"

vg_joesfedora:
 1 : ext4 (Fedora itself)
 2 : swap

3. Attempt to mount the ext4 that contained a Linux distro before starting
Actual results:
Refuses to mount

Expected results:
Mounts the partition okay.

Additional info:
After an attempted mount, dmsg gives me:
bad geometry: block count 27498496 exceeds size of device (27498280 blocks)

Trying resize2fs -f gives me:
Attempt to read block from filesystem resulted in short read while trying to resize /dev/sda5
Please run 'e2fsck -fy /dev/sda5' to fix the filesystem
after the aborted resize operation.

And e2fsck -f gives me:
The filesystem size (according to the superblock) is 27498496 blocks
The physical size of the device is 27498280 blocks
Either the superblock or the partition table is likely to be corrupt!

Trying a backup superblock (as dictated by mke2fs -n) gave the same result.
Comment 1 David Lehman 2012-04-03 11:02:12 EDT
Please find the installation logs in /var/log/anaconda/ and attach the following files from that directory, one at a time, as type text/plain:

  anaconda.log
  anaconda.program.log
  anaconda.storage.log

Thanks.
Comment 2 Joe 2012-04-05 16:13:39 EDT
Created attachment 575542 [details]
Anaconda.log
Comment 3 Joe 2012-04-05 16:14:21 EDT
Created attachment 575543 [details]
Anaconda.program.log
Comment 4 Joe 2012-04-05 16:15:17 EDT
Created attachment 575544 [details]
Anaconda.storage.log
Comment 5 Fedora End Of Life 2013-01-16 08:17:57 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Fedora End Of Life 2013-02-13 09:01:53 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.