Bug 808821 - Installation of new kernel via yum ignores GRUB_DEFAULT entry in /etc/default/grub
Installation of new kernel via yum ignores GRUB_DEFAULT entry in /etc/default...
Status: CLOSED DUPLICATE of bug 742720
Product: Fedora
Classification: Fedora
Component: grubby (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-04-01 04:42 EDT by Elbin Pallimalil
Modified: 2012-05-09 21:01 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 820454 (view as bug list)
Last Closed: 2012-04-08 22:58:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
/etc/default/grub (339 bytes, text/plain)
2012-04-01 04:47 EDT, Elbin Pallimalil
no flags Details
/boot/grub2/grub.cfg (before) (2.32 KB, text/plain)
2012-04-17 14:53 EDT, Elbin Pallimalil
no flags Details
/boot/grub2/grub.cfg (after) (2.95 KB, text/plain)
2012-04-17 14:54 EDT, Elbin Pallimalil
no flags Details

  None (edit)
Description Elbin Pallimalil 2012-04-01 04:42:53 EDT
Description of problem:
I have the following entry in /etc/default/grub
GRUB_DEFAULT="Microsoft Windows XP Professional (on /dev/sda1)"
But when a new kernel is installed via yum this new kernel is made the default.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Set GRUB_DEFAULT to some particular kernel or other entry
2. Install another kernel via yum
Actual results:
The new installed kernel is made the default in Grub

Expected results:
The default boot option should be what was set in GRUB_DEFAULT

Additional info:
Comment 1 Elbin Pallimalil 2012-04-01 04:47:16 EDT
Created attachment 574294 [details]
Comment 2 Elbin Pallimalil 2012-04-08 22:58:43 EDT

*** This bug has been marked as a duplicate of bug 742720 ***
Comment 3 Mads Kiilerich 2012-04-17 06:15:46 EDT
If you say this is a duplicate then so be it. I can imagine other reasons why you could get the behaviour you describe, but without a before-and-after grub.cfg we can't tell.
Comment 4 Elbin Pallimalil 2012-04-17 14:53:16 EDT
Created attachment 578125 [details]
/boot/grub2/grub.cfg (before)

Before adding a new kernel
Comment 5 Elbin Pallimalil 2012-04-17 14:54:23 EDT
Created attachment 578130 [details]
/boot/grub2/grub.cfg (after)
Comment 6 Elbin Pallimalil 2012-04-17 14:56:26 EDT
Added before and after grub.cfg so that you can verify.
Comment 7 Mads Kiilerich 2012-05-09 21:01:19 EDT
Yes, in this case the problem is that whitespace is removed. The 'right' boot entry can thus not be found and grub will pick the first one it finds - which will be the new kernel.

Note You need to log in before you can comment on or make changes to this bug.