Bug 808823 - Cannot build drbd from source rpm - won't compile with this kernel version
Cannot build drbd from source rpm - won't compile with this kernel version
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: drbd (Show other bugs)
16
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Major Hayden
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-01 04:44 EDT by Alexander Murashkin
Modified: 2012-07-11 08:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-11 08:57:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Murashkin 2012-04-01 04:44:40 EDT
Description of problem:

Cannot build drbd packages from the source rpm. Make fails with the following message "won't compile with this kernel version".

Based on drbd/Makefile it does not support build for the current kernel version.

Version-Release number of selected component (if applicable):

drbd-8.3.11-4.fc16
kernel-3.3.0-4.fc16.x86_64

How reproducible:


Steps to Reproduce:
1. Try to build 
rpm -ivh drbd-8.3.11-4.fc16.src.rpm 
cd rpmbuild/SPECS
rpmbuild -bb drbd-8.3.11.spec
  
Actual results:

...
+ make -j3
make -C drbd drbd_buildtag.c
make[1]: Entering directory `/home/mur/rpmbuild/BUILD/drbd-8.3.11/drbd'
Makefile:95: *** "won't compile with this kernel version".  Stop.
make[1]: Leaving directory `/home/mur/rpmbuild/BUILD/drbd-8.3.11/drbd'
make: *** [drbd/drbd_buildtag.c] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.VGNFNK (%build)

Expected results: Sucessfull build

Additional info:

I have modified drbd/Makefile to print more information just to be sure that it extracts patchlevel correctly.

[drbd-8.3.11]$ make
make -C drbd drbd_buildtag.c
make[1]: Entering directory `/home/mur/rpmbuild/BUILD/drbd-8.3.11/drbd'
Makefile:98: *** "won't compile with this kernel version - 
======== KDIR_Makefile_PATCHLEVEL  3 
======== KDIR_Makefile  /lib/modules/3.3.0-4.fc16.x86_64/source/Makefile
". Stop.

# uname -r
3.3.0-4.fc16.x86_64

---- /lib/modules/3.3.0-4.fc16.x86_64/source/Makefile ---

VERSION = 3
PATCHLEVEL = 3
SUBLEVEL = 0
EXTRAVERSION = -4.fc16.x86_64
NAME = Saber-toothed Squirrel

...
Comment 1 Major Hayden 2012-04-01 23:00:00 EDT
I gave this a try tonight, but I couldn't reproduce what you found.  Here's what I tried:

1) Downloaded DRBD source from LINBIT directly and configured/compiled it on Fedora 16 with 3.3.0-8.fc16.x86_64 (3.3.0-4 wasn't available).

2) Built binary RPM's from the DRBD spec file on the same Fedora 16 box.

3) Ran Koji builds for both rawhide and Fedora 17 (both on 3.3.0+).

All three of those succeeded without issue.  It might be worth trying a kernel upgrade on your F16 box to 3.3.0-8 to see if that corrects the problem.
Comment 2 Fedora Update System 2012-04-01 23:02:36 EDT
drbd-8.3.11-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/drbd-8.3.11-5.fc17
Comment 3 Major Hayden 2012-04-01 23:03:52 EDT
Ignore that previous update comment -- attached the wrong ticket in the bodhi update.

Note You need to log in before you can comment on or make changes to this bug.