Bug 80883 - mouse movement caused display to scroll
mouse movement caused display to scroll
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-01 13:52 EST by Don Church
Modified: 2007-04-18 12:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-24 14:51:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
1 of 2 xfree86 config files found (276 bytes, text/plain)
2003-01-02 21:15 EST, Don Church
no flags Details
2 of 2 xfree86 config files found (86 bytes, text/plain)
2003-01-02 21:17 EST, Don Church
no flags Details
/var/log/messages as requested (63.66 KB, text/plain)
2003-02-11 21:36 EST, Don Church
no flags Details

  None (edit)
Description Don Church 2003-01-01 13:52:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
after fresh install, under root, switched to kde, logged out and immediately
back on. Vertical mouse movement caused display to scroll while mouse pointer
remained at top of screen.  horizontal movement ran along extreme top only. 
after reboot, works fine.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:
Comment 1 Mike A. Harris 2003-01-02 04:56:16 EST
Mouse movement has nothing whatsoever to do with switchdesk.  What
brand/make/model of mouse do you have?

Please attach your XFree86 config file and X server log file as individual
file attachments, from the configuration that you experience the problem with.

Also, is gpm running while this occurs?
Comment 2 Don Church 2003-01-02 21:15:40 EST
Created attachment 89080 [details]
1 of 2 xfree86 config files found
Comment 3 Don Church 2003-01-02 21:17:35 EST
Created attachment 89081 [details]
2 of 2 xfree86 config files found
Comment 4 Don Church 2003-01-02 22:05:25 EST
I found 7 xserver plain text files.  Not sure which is requested.  gpm was
running, mouse is Logitech TrackMan Marble FX.
Also, I have the same scolling problem when I allow the system to auto-login.  I
used GDM Setup to change from graphic greeter to standard greeter, then selected
a .jpg file for a background image scaled to fit.  I selected a timed login
option set to 5 seconds.  Now the original problem occurred when I switched from
gnome to kde with my root login, and my regular user login "don" is still gnome.
 So now when I let it log in by itself, whenever I move the mouse the display
scrolls between the default gnome desktop and the .jpg standard greeter screen.
 I am still able to select items from menus and such, but still, any vertical
movement of the mouse will just move my desktop and the pointer stays at the
top.  I was able to select logout during the problem but the screen went black
and I couldn't tell what was happening and couldn't get any response using cntl
alt del, so I reset.  After reboot, I logged in as don manually and it seems fine.
   Another interesting thing is I booted rh8.0 , the stable release (same
machine since I'm using "BootIt" to manage several os's) which I have up to date
in the rh network, and I also set up the auto login option as described above,
but uses kde desktop, anyway, it does the same thing only worse.  It doesn't
normal menus, they're deformed, showing maybe a slash "/" or something for each
entry in a menu and everything out of place and non functional, had to reset. 
I'm sure you know I disabled auto login.
Comment 5 Warren Togami 2003-01-23 04:59:36 EST
I saw this behavior once in Phoebe1 (but not Phoebe2).  I last saw this behavior
back in Red Hat 7.2 beta, a buggy X driver (nv) kept graphics mode running when
I hit CTRL-ALT-F1.  Moving the mouse caused the display to scroll and hitting
enter on the keyboard made it scroll vertically.  Clicking did nothing.  Keys in
this state behaved like a text tty, so CTRL-ALT-F7 brought me back into the real X.

I am unable to reproduce this bug in Phoebe2.
Comment 6 Mike A. Harris 2003-01-23 06:43:14 EST
Don, please test the latest beta release, the second phoebe beta out
and see if you get the same results as Warren above.

I'm assuming this problem no longer occurs now based on Warren's feedback,
and putting it into the MODIFIED state, awaiting confirmation.

If the problem persists, please set the state back to ASSIGNED, or if the
problem is resolved please set the state to RAWHIDE.

Thanks.
Comment 7 Don Church 2003-01-28 18:00:35 EST
I downloaded Phoebe 8.0.92 I think(got it 1-25-03) and initially just upgraded
old Phoebe.  Everything seemed to work fine so I did a fresh install, accepted
defaults for workstation plus added kde desktop and development and samba/swat.
 Basically the same problem occurred except worse.  Now when I switch to kde,
exit and allow the auto-login, the screen scrolls, mouse click DO work, but
still in Gnome. (didn't switch desktops)  I'm pretty sure it actully went to kde
using phoebe-1.  Something else, not sure if related but whenever I log out, the
display goes blank (black).  I think it's still working, just can't see. 
Sometimes the monitor goes to power save mode and others just black.  One thing
to note here is that I haven't found any distribution (3or4) that can
successfully reset my video (display).  It goes black and doesn't come back
until I reset the box switch.  (Tyan Tiger s2460 bios 1.04 and Radeon 8500) Also
tried the Enter key (did nothing) ctl alt f1 (got the command line) ctl alt f7
(put monitor to sleep).  Something else is that the last time I tried to switch
to kde, it scrolled horizontally with the mouse stuck to the left side (still
clicked ok).
Comment 8 Mike Chambers 2003-02-10 22:31:41 EST
Don,

You might try posting your /var/log/messages when this problem happens as it 
might show something to help troubleshoot.
Comment 9 Don Church 2003-02-11 21:36:46 EST
Created attachment 90018 [details]
/var/log/messages as requested

On the second boot documented I reset when I got tired of waiting for
"sendmail" to initialize.
Comment 10 Don Church 2003-02-11 21:59:35 EST
I re-installed and messed around in gnome with the display setting (resolution),
played Chromium, and tried to turn off the services that I don't need (didn't
work from user "don") and changed host name to "dons" from network settings. 
All seemed ok.  I did get an error on the firstboot telling me the time
application  of some sort failed and to send a bug report with the file it
created, also before I changed the hostname an error about not logging on
successfully with dhccp2 or whatever the default hostname was and gave the
option to log on anyway.  finally I used the desktop switching tool to switch to
kde (notice I didn't mess with autologin this time) and as soon as I logged out,
the screen started scrolling vertically between the gnome desktop and the login
screen.  I don't remember logging back in, so I must have logged out again from
the desktop, still working, just moving, and then the same problem with a blank
screen, so I used ctl alt f1 (I think) to get to login at the command line and
then halted the system.  Came back later and booted as root to turn off sendmail
and other and to get the attachment copied to a common partition with 8.0(orig)
Comment 11 Mike A. Harris 2004-09-24 14:51:52 EDT
Please upgrade to Fedora Core 2 or later, and if this issue turns
out to still be reproduceable, please file a bug report in the
X.Org bugzilla located at http://bugs.freedesktop.org in the
"xorg" component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.

Note You need to log in before you can comment on or make changes to this bug.