Bug 80892 - Notify user when architecture is not supported (ie, no kernel package exists)
Notify user when architecture is not supported (ie, no kernel package exists)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2003-01-01 15:56 EST by David Chambers
Modified: 2007-04-18 12:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:56:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Diagnostic Dump via floppy (76.62 KB, text/plain)
2003-01-01 15:58 EST, David Chambers
no flags Details

  None (edit)
Description David Chambers 2003-01-01 15:56:22 EST
Description of problem:

Anaconda crashes when creating the recommended rescue disk toward the end of 
the installation process, indicating a bug. This occurs independent of whether 
GRUB or LILO Loader is selected. Previous notification message indicated that 
(despite being a clean new all Linux installation) no Kernel packages were 
loaded, so the boot loader/config had not been updated. Disks and floppy have 
been double checked/reformatted, and same result happens 4 or 5 times, 
regardless of build (workstation, server etc).

This is a text mode installation on a very simple and old Dell 486P machine, 
using a newish high speed CDROM. Memory 40MBytes, Disk 6GB, Processor 
486/33DX, onboard bog standard VGA graphics with 1K video RAM.

If I skip this option (ie make no disk) the installation completes but does 
not boot, because BIOS cannot find any boot record.

BIOS can only see 504MBytes of disk, but boots successfully into a 10MB MSDOS 
partition at the start of the disk.

Error message was:
File /usr/bin/anaconda line 694 in intf.run(id,dispatch,ConfigFileData)
File /usr/text/anaconda/text.py line 446
in run dispatch.gotoNext()

Version-Release number of selected component (if applicable):


How reproducible:
Every time - I have tried this 4 or 5 times, double checked/used different the 
media (floppies, CDROMs etc), and whether selected GRUB or LILO boot loader


Steps to Reproduce:
1. Text install booted from floppy using CDROM disks, Linux only machine
2. Agree to create boot/rescue floppy disk toward end of installation
3. Crash when trying to write to floppy
    
Actual results:
Crashes every time with error message (indicating a bug) in anaconda program

Expected results:
Create floppy (or give graceful error message)

Additional info:
I will append the debug dump via a floppy to this bug report after filing, but 
the top part is included below:
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 694, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/text.py", line 446, in run
    dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/floppy.py", line 59, in makeBootdisk
    kernel = hdList['kernel']
  File "/usr/lib/anaconda/comps.py", line 171, in __getitem__
    return self.packages[item]
KeyError: kernel

Local variables in innermost frame:
item: kernel
self:
Comment 1 David Chambers 2003-01-01 15:58:25 EST
Created attachment 89040 [details]
Diagnostic Dump via floppy

Dump produced when installer crashes
Comment 2 Michael Fulbright 2003-01-02 16:41:18 EST
You need to have a Pentium processor as a minimum.

Jeremy we need to make sure we catch this earlier. I think you were working on
making sure a kernel package exists?
Comment 3 Jeremy Katz 2003-01-02 16:48:49 EST
Already done in CVS
Comment 4 Brent Fox 2003-05-25 10:56:36 EDT
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.

Note You need to log in before you can comment on or make changes to this bug.