This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 808938 - moving /tmp to RAM fails to boot
moving /tmp to RAM fails to boot
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
17
All Linux
unspecified Severity high
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-01 17:32 EDT by patrick korsnick
Modified: 2012-04-02 15:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-02 15:55:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description patrick korsnick 2012-04-01 17:32:06 EDT
Description of problem:

Trying to move /tmp to RAM to avoid extra writes to an SSD used as root drive.
Adding this line to /etc/fstab worked for me on f16:

none    /tmp    tmpfs   defaults        0 0

However on f17 adding this line prevents the machine from booting.


Version-Release number of selected component (if applicable):

17

How reproducible:

every boot fails

Steps to Reproduce:
1. add above line to /etc/fstab
2. reboot
3.
  
Actual results:

boot halts 

Expected results:

machine to boot up

Additional info:
Comment 1 Michal Schmidt 2012-04-02 11:56:30 EDT
Works for me. What exact versions of systemd and util-linux packages do you have? Could you attach the whole fstab?
Comment 2 patrick korsnick 2012-04-02 15:40:49 EDT
util-linux-2.21.1-1.fc17.x86_64
systemd-44-4.fc17.x86_64
systemd-sysv-44-4.fc17.x86_64

#
# /etc/fstab
# Created by anaconda on Tue Mar 27 14:45:15 2012
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
UUID=c743fee5-9d6b-41ae-87e9-a658b77663c4 /                       ext4    noatime,discard,data=writeback        1 1
UUID=0ae2a4bd-fa04-4b59-9dc4-5ff3f023fb5a swap                    swap    defaults        0 0
#
# ppk - move /tmp to RAM
#                                                                                                                                                 
none /tmp tmpfs defaults 0 0
Comment 3 patrick korsnick 2012-04-02 15:55:52 EDT
Rebooting with setup in Comment 2 machine booted successfully. Must have gotten fixed sometime after the Alpha was released, because it was broken then. Closing bug as fixed.

Note You need to log in before you can comment on or make changes to this bug.