Bug 808983 - pdebuild script fails
pdebuild script fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Krzysztof Daniel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-02 02:38 EDT by Krzysztof Daniel
Modified: 2014-01-12 19:26 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-11 03:19:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krzysztof Daniel 2012-04-02 02:38:52 EDT
Most of Eclipse plugins are marked as noarch, while the pdebuild script is actually arch specific.
It is possible that wrong version of pdebuild script is installed on a build server, or the package refers to the wrong version (f.e. 32 bit build refers to the 64 bit path), and the build fails.
Comment 1 Alexander Kurtakov 2012-04-02 03:21:44 EDT
I don't see how can this happen. We evaluate the path to pdebuild to always be _libdir/eclipse/buildscripts/pdebuild.sh so the only possibility for this to happen is _libdir giving wrong value aka /usr/lib on 64bit or /usr/lib64 on 32bit which is something that I haven't seen in quite some time.
Comment 2 Krzysztof Daniel 2012-04-02 03:43:03 EDT
I have seen this with mylyn quite often.
I have found multiple reports that when a noarch package is being built, its dependencies can be satisfied either by x86 or by x86_64 package, and they are not matches with the builder platform.

I think we need to use ISA macros:
http://rpm.org/wiki/PackagerDocs/ArchDependencies
Comment 3 Krzysztof Daniel 2012-04-11 03:19:52 EDT
The problem is solved by:
* installing the pdebuild script into bindir (bug 790733)
* having special eclipse macro that is correctly resolved when building noarch packages.

Note You need to log in before you can comment on or make changes to this bug.