Bug 808997 - Hauppauge WinTV-HVR4000 DVB-S/S2/T/Hybrid no longer works properly with kernel 3.3
Hauppauge WinTV-HVR4000 DVB-S/S2/T/Hybrid no longer works properly with kerne...
Status: CLOSED DUPLICATE of bug 808871
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Mauro Carvalho Chehab
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-02 03:52 EDT by thestonewell
Modified: 2013-07-04 18:59 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-09 09:32:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description thestonewell 2012-04-02 03:52:18 EDT
Description of problem:

I have got 2 Hauppauge WinTV-HVR4000 DVB-S/S2/T/Hybrid cards in my
system. They worked perfectly fine with kernel 3.2 (e.g. the last
Fedora 16 kernel that worked is 3.2.10-3.fc16.x86_64).

As soon as Fedora went kernel 3.3 (kernel 3.3.0-4.fc16.x86_64) the
problems started. The cards are still recognized and you can tune
them. But trying to watch any DVB-S (or DVB-S2) channel just results
in block artefacts, loss of audio-video sychronization etc. The only
thing /var/log/messages or dmesg tells me is:


cx8802_start_dma() Failed. Unsupported value in .mpeg (0x00000001)

Same machine, same everything, just rebooting back into the 3.2 kernel
the problem is gone.


Version-Release number of selected component (if applicable):

3.3.0-4.fc16.x86_64 or later

How reproducible:

always

Steps to Reproduce:
1. boot into kernel 3.3
2. watch dvb-s with hardware
3.
  
Actual results:


Expected results:


Additional info:

I got pointed to the patch at http://www.spinics.net/lists/linux-media/msg45592.html
Comment 1 Jens Hektor 2012-04-09 03:17:01 EDT
Should be a duplicate of bug #808871
Comment 2 Josh Boyer 2012-04-09 09:32:46 EDT

*** This bug has been marked as a duplicate of bug 808871 ***
Comment 3 shishir gowda 2012-05-08 00:35:53 EDT
*** Bug 810103 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.