Bug 8090 - Installation fails (system halts) when using A/B switch
Installation fails (system halts) when using A/B switch
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-31 13:36 EST by Noam Gonnen
Modified: 2015-01-07 18:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-09 22:19:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noam Gonnen 1999-12-31 13:36:29 EST
When the Linux installs, and the machine is connected to I/O devices (monitor/kbd/mouse) via A/B
switch (e.g user with multiple PCs, accessible via the same set of kbd/monitor, in my case. the
mouse was seperated per PC) a problem rises.

After packages installation is over a stage called "Post Configuration" is commited (a msgbox with
caption "Performing post install configurations")
If while packages installation ends, and moving to the above mentioned stage, the PC is not
accessible to the former mentioned devices, the installation stands still, with the msgwnd
lingering endlessly.

The system halts, thus forces user to cold boot and repeat the whole installation.

Note: The least one can do is have the HW connectivity dependancy well documented (at the help bar
on the left side of the installed wizard)

thanks.(happy y2k)
noamg@gilat.com
Comment 1 Jay Turner 2000-02-09 22:18:59 EST
This is not a bug, as all through the installation process, probing is performed
on the hardware.  If that hardware is not present, then it is expected there
will be problems with the installer.  This is the same as disconnecting the
keyboard during the install.  Any installation will fail under this condition.
Comment 2 Noam Gonnen 2000-02-10 08:26:59 EST
I totaly accept the resolution comments, yet, I think a better comment could be made available to cout
(i.e the display) instead of having the system freeze with no "tip" (e.g. - pls check you kbd/mouse for
connection , or any other string that comes to mind.)
thanks,Noam.

Note You need to log in before you can comment on or make changes to this bug.