Bug 809001 - -devel subpackage should require dbus-devel
-devel subpackage should require dbus-devel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: at-spi2-core (Show other bugs)
rawhide
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-02 04:06 EDT by Daiki Ueno
Modified: 2012-04-16 22:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-16 22:49:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daiki Ueno 2012-04-02 04:06:51 EDT
Description of problem:

The pkg-config script provided by at-spi2-core-devel package requires "dbus-1".  However, "yum install at-spi2-core-devel" does not pull the package providing "dbus-1".

Version-Release number of selected component (if applicable):
at-spi2-core-2.4.1-1

How reproducible:
always

Steps to Reproduce:
1. in mock or minimal installation, do yum install at-spi2-core-devel
2. pkg-config atspi-2 --libs
3.
  
Actual results:
Package dbus-1 was not found in the pkg-config search path.
Perhaps you should add the directory containing `dbus-1.pc'
to the PKG_CONFIG_PATH environment variable
Package 'dbus-1', required by 'atspi', not found
zsh: exit 1     pkg-config atspi-2 --libs

Expected results:
-L/lib64 -latspi -ldbus-1 -lpthread -lrt

Additional info:
Comment 1 Kalev Lember 2012-04-16 22:13:25 EDT
pkg-config deps are automatically handled by rpmbuild.

Latest at-spi2-core-devel-2.4.1-1.fc17.x86_64.rpm [1] has automatically generated Requires: pkgconfig(dbus-1). The matching virtual Provides are in dbus-devel:
$ repoquery -q --whatprovides 'pkgconfig(dbus-1)'
dbus-devel-1:1.4.10-4.fc17.x86_64
dbus-devel-1:1.4.10-4.fc17.i686

I can't see anything wrong with the deps; everything seems to be working as it is supposed to be.

[1 http://koji.fedoraproject.org/koji/rpminfo?rpmID=3065570
Comment 2 Daiki Ueno 2012-04-16 22:49:19 EDT
(In reply to comment #1)
> pkg-config deps are automatically handled by rpmbuild.
[...]
> I can't see anything wrong with the deps; everything seems to be working as it
> is supposed to be.

Sorry, you are right.  Probably there was something wrong in my local mock setup.

Note You need to log in before you can comment on or make changes to this bug.