Bug 809126 - SELinux is preventing /usr/sbin/groupadd from 'unlink' accesses on the file group.
SELinux is preventing /usr/sbin/groupadd from 'unlink' accesses on the file g...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:a4ed33d8d6352ba715e091a3223...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-02 10:37 EDT by Tom
Modified: 2012-04-02 15:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-02 15:12:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom 2012-04-02 10:37:05 EDT
libreport version: 2.0.10
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.4.0-0.rc0.git4.2.fc18.x86_64
time:           Mon 02 Apr 2012 10:35:09 AM EDT

description:
:SELinux is preventing /usr/sbin/groupadd from 'unlink' accesses on the file group.
:
:*****  Plugin catchall_labels (83.8 confidence) suggests  ********************
:
:If you want to allow groupadd to have unlink access on the group file
:Then you need to change the label on group
:Do
:# semanage fcontext -a -t FILE_TYPE 'group'
:where FILE_TYPE is one of the following: pcscd_var_run_t, shadow_t, passwd_file_t. 
:Then execute: 
:restorecon -v 'group'
:
:
:*****  Plugin catchall (17.1 confidence) suggests  ***************************
:
:If you believe that groupadd should be allowed unlink access on the group file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep groupadd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:system_r:groupadd_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:etc_t:s0
:Target Objects                group [ file ]
:Source                        groupadd
:Source Path                   /usr/sbin/groupadd
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           shadow-utils-4.1.5-2.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-104.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.4.0-0.rc0.git4.2.fc18.x86_64 #1
:                              SMP Thu Mar 29 19:52:35 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Mon 02 Apr 2012 10:24:20 AM EDT
:Last Seen                     Mon 02 Apr 2012 10:24:20 AM EDT
:Local ID                      70ef193e-d185-45f9-af22-06d5acfbbc7e
:
:Raw Audit Messages
:type=AVC msg=audit(1333376660.89:93): avc:  denied  { unlink } for  pid=9713 comm="groupadd" name="group" dev="dm-2" ino=1313961 scontext=unconfined_u:system_r:groupadd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:etc_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1333376660.89:93): arch=x86_64 syscall=rename success=yes exit=0 a0=7fff9db48530 a1=7f54dd16b5a0 a2=7fff9db484a0 a3=ffffffff items=0 ppid=9712 pid=9713 auid=1000 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts2 ses=1 comm=groupadd exe=/usr/sbin/groupadd subj=unconfined_u:system_r:groupadd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: groupadd,groupadd_t,etc_t,file,unlink
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Tom 2012-04-02 11:06:21 EDT
Happened during yum install
Comment 2 Daniel Walsh 2012-04-02 15:12:47 EDT
restorecon -R -v /etc

And reopen if this happens again.  I guess this could be caused by a problem in first boot.

Note You need to log in before you can comment on or make changes to this bug.