This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 809152 - Move session pam_gnome_keyring.so after pam_systemd.so
Move session pam_gnome_keyring.so after pam_systemd.so
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-02 11:35 EDT by Stef Walter
Modified: 2012-04-18 18:48 EDT (History)
1 user (show)

See Also:
Fixed In Version: gdm-3.4.1-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 18:48:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Move session pam_gnome_keyring.so so after pam_systemd.so (1.95 KB, patch)
2012-04-02 11:36 EDT, Stef Walter
no flags Details | Diff

  None (edit)
Description Stef Walter 2012-04-02 11:35:09 EDT
The session pam_gnome_keyring.so now needs to be run after pam_systemd.so. It seems that pam_systemd.so sets XDG_RUNTIME_DIR. 

This is because of this change in gnome-keyring 3.4.0:

https://bugzilla.gnome.org/show_bug.cgi?id=646389
Comment 1 Stef Walter 2012-04-02 11:36:52 EDT
Created attachment 574543 [details]
Move session pam_gnome_keyring.so so after pam_systemd.so
Comment 2 Fedora Update System 2012-04-02 18:18:01 EDT
gdm-3.4.0.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gdm-3.4.0.1-2.fc17
Comment 3 Fedora Update System 2012-04-04 17:08:33 EDT
Package gdm-3.4.0.1-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gdm-3.4.0.1-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5281/gdm-3.4.0.1-2.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-04-05 23:30:55 EDT
gdm-3.4.0.1-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gdm-3.4.0.1-3.fc17
Comment 5 Fedora Update System 2012-04-09 14:33:20 EDT
gdm-3.4.0.1-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gdm-3.4.0.1-4.fc17
Comment 6 Fedora Update System 2012-04-14 15:25:50 EDT
gdm-3.4.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gdm-3.4.1-1.fc17
Comment 7 Fedora Update System 2012-04-18 18:48:41 EDT
gdm-3.4.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.