Bug 809160 - Cannot install Windows 8 Beta using virt-manager on KVM
Cannot install Windows 8 Beta using virt-manager on KVM
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Virtualization_Host_Configuration_and_Guest_Installation_Gui (Show other bugs)
6.2
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Laura Bailey
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-02 12:00 EDT by John Poelstra
Modified: 2013-01-09 19:50 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-27 08:56:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot 1 (32.90 KB, image/png)
2012-04-02 12:01 EDT, John Poelstra
no flags Details
screen shot 2 (29.93 KB, image/png)
2012-04-02 12:01 EDT, John Poelstra
no flags Details
xmldump (2.75 KB, text/plain)
2012-04-02 20:08 EDT, John Poelstra
no flags Details
log (1.27 KB, text/plain)
2012-04-02 20:08 EDT, John Poelstra
no flags Details

  None (edit)
Description John Poelstra 2012-04-02 12:00:23 EDT
Description of problem:

Cannot install Windows 8 Beta using virt-manager on KVM because the Windows installer complains of a missing driver.  I'm not sure if this is a Windows or a RHEL problem.  I asked some people at Red Hat and they asked that I file this bug.

Version-Release number of selected component (if applicable):
$ rpm -qa | grep virt
libvirt-client-0.9.4-23.el6_2.7.x86_64
libvirt-python-0.9.4-23.el6_2.7.x86_64
python-virtinst-0.600.0-5.el6.noarch
libvirt-0.9.4-23.el6_2.7.x86_64
virt-manager-0.9.0-7.el6.x86_64
virt-what-1.11-1.1.el6.x86_64
virt-viewer-0.4.1-7.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Download Windows 8 64bit beta
2. Attempt to boot the install ISO in a KVM guest (Selected Windows 7 as the install OS in virt-manager wizzard)
3.
  
Actual results:
Doesn't work--see screen captures
Comment 1 John Poelstra 2012-04-02 12:01:05 EDT
Created attachment 574547 [details]
screen shot 1
Comment 2 John Poelstra 2012-04-02 12:01:39 EDT
Created attachment 574548 [details]
screen shot 2
Comment 4 John Poelstra 2012-04-02 12:03:18 EDT
I was just installing this for fun after hearing the beta was public and free.

http://www.businessinsider.com/windows-8-consumer-preview-2012-2
Comment 5 Dave Allan 2012-04-02 12:09:58 EDT
Does it give any indication of what driver is missing?  I didn't see any, but I didn't look at it at great length.
Comment 6 John Poelstra 2012-04-02 13:16:53 EDT
(In reply to comment #5)
> Does it give any indication of what driver is missing?  I didn't see any, but I
> didn't look at it at great length.

It says a DVD driver (see the screen shot).  Beyond that I have no idea, nor any idea how/where to look.
Comment 7 Dave Allan 2012-04-02 13:27:11 EDT
Huh, I saw that	and didn't quite know what to make of it and read it
as "you	need to	put in the DVD with the	driver"--admittedly a strained interpretation.
Comment 8 John Poelstra 2012-04-02 14:31:26 EDT
(In reply to comment #7)
> Huh, I saw that and didn't quite know what to make of it and read it
> as "you need to put in the DVD with the driver"--admittedly a strained
> interpretation.

Yes, that was my first thought.  I shut the VM down and thought, "Oh well, I can't try this because I don't have the right DVD driver."  

Later as I thought about it more I wondered, "If I really wanted to make this work, where would I get the 'missing driver?'  Should it be provided by the Windows installer or is something missing from virt-manager?"
Comment 9 Cole Robinson 2012-04-02 17:58:19 EDT
Unless windows has dropped support for IDE dvd drives this should presumably just work. Maybe something missing in qemu IDE emulation. Moving to qemu-kvm for further triage.

John, can you attach:

sudo virsh dumpxml $vmname
/var/log/libvirt/qemu/$vmname.log
Comment 10 Ademar Reis 2012-04-02 18:48:14 EDT
Please post the command line used to invoke qemu as well, you can obtaiin that with the output of this command once the VM is running:

$ ps ax | grep qemu-kvm
Comment 11 John Poelstra 2012-04-02 20:06:17 EDT
(In reply to comment #10)
> Please post the command line used to invoke qemu as well, you can obtaiin that
> with the output of this command once the VM is running:
> 
> $ ps ax | grep qemu-kvm

# ps ax | grep qemu-kvm
26465 ?        Sl     1:18 /usr/libexec/qemu-kvm -S -M rhel6.2.0 -enable-kvm -m 1024 -smp 2,sockets=2,cores=1,threads=1 -name win8 -uuid bffbd003-ef2b-87b4-68b1-66582660c4e1 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/win8.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -no-reboot -no-shutdown -drive file=/var/lib/libvirt/images/win8.img,if=none,id=drive-ide0-0-0,format=raw,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=2 -drive file=/home/jp/Downloads/Windows8-ConsumerPreview-64bit-English.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0,bootindex=1 -netdev tap,fd=23,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:57:ac:9b,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -usb -device usb-tablet,id=input0 -vnc 127.0.0.1:0 -vga std -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x5
26835 pts/13   S+     0:00 grep qemu-kvm
Comment 12 John Poelstra 2012-04-02 20:08:07 EDT
Created attachment 574684 [details]
xmldump
Comment 13 John Poelstra 2012-04-02 20:08:36 EDT
Created attachment 574685 [details]
log
Comment 14 Dan Yasny 2012-04-03 03:24:53 EDT
I have a win8 VM installed and running just fine, using QXL and virtio_net and virtio_blk. 

Works just fine except that the QXL driver doesn't install, complaining about "unknown operating system"
Comment 15 Ronen Hod 2012-04-03 05:04:19 EDT
Yan also managed to install Win8. I believe that KVM is OK with Win8.
Comment 16 Ademar Reis 2012-05-04 10:29:59 EDT
John, can you try the latest packages from RHEL6.3? We have two reports of succesful installs, so it's either already fixed or something else we have to pinpoint in your setup.
Comment 17 John Poelstra 2012-05-04 10:47:19 EDT
(In reply to comment #16)
> John, can you try the latest packages from RHEL6.3? We have two reports of
> succesful installs, so it's either already fixed or something else we have to
> pinpoint in your setup.

Sorry, nothing has changed.  It still doesn't work for me and I get the same error messages.

$ rpm -qa | grep virt
libvirt-python-0.9.10-16.el6.x86_64
libvirt-0.9.10-16.el6.x86_64
libvirt-client-0.9.10-16.el6.x86_64
virt-viewer-0.5.2-6.el6.x86_64
virt-what-1.11-1.1.el6.x86_64
virt-manager-0.9.0-13.el6.x86_64
python-virtinst-0.600.0-8.el6.noarch

$ cat /etc/redhat-release 
Red Hat Enterprise Linux Workstation release 6.3 Beta (Santiago)

I did however, go to http://windows.microsoft.com/en-US/windows-8/iso

The sha1 of the iso I have is different from the one currently posted there.  I'm downloading what's presently there and will try it out and report back.
Comment 18 John Poelstra 2012-05-04 12:30:26 EDT
(In reply to comment #17)
> I did however, go to http://windows.microsoft.com/en-US/windows-8/iso
> 
> The sha1 of the iso I have is different from the one currently posted there. 
> I'm downloading what's presently there and will try it out and report back.


Downloaded new ISO, this time it requires a key.  Ran and walked through installer and ended up with similar error messages about missing driver.

I don't see how this is "unique to my setup."  I'm just running virt-manager.
Comment 20 Mike Cao 2012-05-06 10:52:53 EDT
Hi, John/all

I have a win8-64bit customer consumer version guests running under virt-manager .And It was used as my desktop for more than 2 months , I also installed developer-preview version ,and I did not hit any problem  

John ,From your screendump ,I think you install win8 w/ virtio disk ,while you did not attach the PV drivers (virtio-win.iso),

Could you download virtio-win package from brewweb, install it .then attach the /usr/share/virtio-win/virtio-win.vfd during guest install (you can install the driver located in win7)? 


Thanks,
Mike
Comment 21 Mike Cao 2012-05-06 23:27:59 EDT
Re-installed one win8 Customer Privew 64 bit version  w/ ide disk .
Guest finish installation successfully w/o any error
Comment 22 John Poelstra 2012-05-07 11:50:42 EDT
(In reply to comment #20)
> Hi, John/all
> 
> I have a win8-64bit customer consumer version guests running under virt-manager
> .And It was used as my desktop for more than 2 months , I also installed
> developer-preview version ,and I did not hit any problem  
> 
> John ,From your screendump ,I think you install win8 w/ virtio disk ,while you
> did not attach the PV drivers (virtio-win.iso),
> 

Hmm..

1) How would I have known that I needed to install virtio-win.iso?

2) Once I install virtio-win what am I supposed to do differently?

3) What does it mean that I "did not attach the PV drivers?"

Can you point me to any relevant docs on this subject? I naively thought I could just follow the virt-manager wizzard and install Windows. :)
Comment 23 Laura Bailey 2012-05-24 18:57:10 EDT
Hi John,

I think the steps you're looking for should be covered in this section of the Virtualization Host Configuration and Guest Installation Guide:

http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6-Beta/html/Virtualization_Host_Configuration_and_Guest_Installation_Guide/form-Virtualization_Host_Configuration_and_Guest_Installation_Guide-Para_virtualized_drivers-Mounting_the_image_with_virt_manager.html

Note that this is a link to the beta documentation for 6.3, as it has updated screenshots. The doc will reside at the following link once RHEL 6.3 goes live:

http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Virtualization_Host_Configuration_and_Guest_Installation_Guide/form-Virtualization_Host_Configuration_and_Guest_Installation_Guide-Para_virtualized_drivers-Mounting_the_image_with_virt_manager.html

Obviously at this point we do not have specific instructions for Windows 8, but I'll work on adding them as soon as we get our hands on a stable release. :) If Section 10.1 and its subsections don't answer your question, please let me know.
Comment 24 John Poelstra 2012-05-24 19:39:48 EDT
(In reply to comment #23)
Interesting.  Without knowing those steps I found 'virtio-win.noarch' in the supplementary repo and was able install and use the Windows 8 beta after I installed it.

I got things to work by simply yum installing 'virtio-win.noarch' and re-running the steps I did before using the wizzard.  I did not point point at the virtio-win.iso... maybe I got whatever was on that from yum installing 'virtio-win.iso?'
Comment 26 Ronen Hod 2012-05-27 08:56:52 EDT
Since we do not officially support Win8, I am closing it as NOTABUG. It is certain that once Win8 is officially available we will not forget to support it and verify that it installs well, so there is no need to keep this bug open in order to remind us.

Thanks, Ronen.

Note You need to log in before you can comment on or make changes to this bug.