Bug 809172 - Feature Request: Implement the ability to be able to tune vnetX devices tunables such as txqueuelen
Feature Request: Implement the ability to be able to tune vnetX devices tunab...
Status: CLOSED DEFERRED
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Privoznik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-02 12:38 EDT by Tim Hughes
Modified: 2016-04-26 09:26 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-31 06:32:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Hughes 2012-04-02 12:38:59 EDT
Feature Request:

setting the txqueuelen on vnetX devices to 2500 we can increase the network throughput by a factor of almost 10. On an eth device it can be set by  hand/rc.local with the following instructions http://www.cyberciti.biz/faq/gentoo-centos-rhel-debian-fedora-increasing-txqueuelen/  .  Because vnetX devices are named on a 'first free' basis and they come and go with the guests, the rc.local method is not going to work. 

Ideally I would like to be able to set this automatically for all vnetX devices when they are created or even better, on a per guest basis.
Comment 2 Umberto Boscolo 2014-03-31 10:16:25 EDT
the proposed solution works fine, but I guess all the VMs/vnets will have the same txqueuelen as configured in /etc/udev/...? 
What happens if I want to customize different VMs/vnet with different txqueuelen. 

The proper solution would be to be able to specify the txquelen in the xml description instead on a per vnet basis

Is there still an interest in this enhancement?
Comment 3 Tim Hughes 2014-12-31 06:26:08 EST
We have dropped virtualization for all our production systems. The solution above works for us in because we use puppet to manage it on any system that requires it so unless anyone else is after the feature then I would put it at the bottom of the list or drop it.
Comment 4 Michal Privoznik 2014-12-31 06:32:47 EST
Okay, closing per comment 3. If anybody find out that they need this, please feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.