This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 809195 - Post sync url not working with scheduled sync.
Post sync url not working with scheduled sync.
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jason Connor
Preethi Thomas
: Reopened
Depends On:
Blocks: 802454
  Show dependency treegraph
 
Reported: 2012-04-02 13:44 EDT by Justin Sherrill
Modified: 2014-03-30 21:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-25 10:16:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2012-04-02 13:44:02 EDT
How reproducible:
always

Steps to Reproduce:
1.  Set the post_sync_url
2.  Create a repo
3.  Assign a sync schedule to it
4.  Wait for sync to finish
  
Actual results:
post_sync_url is never POST'ed to.

Expected results:
post_sync_url is POST'ed to.


Immediate syncs seem to work fine, url is POST'ed to as expected.
Comment 1 Jason Connor 2012-04-02 16:19:14 EDT

*** This bug has been marked as a duplicate of bug 802454 ***
Comment 2 Jason Connor 2012-04-02 16:29:10 EDT
Functionally a duplicate, yes, but against the wrong product. Reopening.
Comment 3 Jason Connor 2012-04-02 16:58:11 EDT
added post_sync dequeue callback to scheduled syncs
fix pushed in:
cc8fb3006579b82fb7a67de9f903c2e44449fe63
Comment 4 Jeff Ortel 2012-04-03 14:49:02 EDT
build: 1.0.3
Comment 5 Preethi Thomas 2012-04-03 16:24:22 EDT
[root@pulp-v1-server ~]# rpm -q pulp
pulp-1.0.3-1.el6.noarch

[server]
server_name: pulp-v1-server.usersys.redhat.com
relative_url: /pulp/repos
key_url: /pulp/gpg
ks_url: /pulp/ks
default_login: admin
default_password: admin
post_sync_url: https://localhost/pulp/api/sync/post_action


[root@pulp-v1-server ~]#  pulp-admin repo create --id zoo --feed http://inecas.fedorapeople.org/fakerepos/zoo/ --relativepath zoo
Successfully created repository [ zoo ]

[root@pulp-v1-server ~]# pulp-admin repo sync --id=zoo --interval=PT5M --start=2012-02-07T12:40:00-01:00:00
Sync schedule for repo [ zoo ] changed to [ 2012-02-07T12:40:00-01:00/PT5M ]
[root@pulp-v1-server ~]# 


From

[root@pulp-v1-server ~]# tail -f /var/log/httpd/ssl_access_log

10.16.120.248 - - [03/Apr/2012:16:09:42 -0400] "PUT /pulp/api//repositories/zoo/schedules/sync/ HTTP/1.1" 200 123
::1 - - [03/Apr/2012:16:10:10 -0400] "POST /pulp/api/sync/post_action HTTP/1.1" 404 9
::1 - - [03/Apr/2012:16:15:17 -0400] "POST /pulp/api/sync/post_action HTTP/1.1" 404 9
Comment 6 Preethi Thomas 2012-04-04 08:50:21 EDT
[root@pulp-v1-server ~]# rpm -q pulp
pulp-1.0.4-1.el6.noarch
[root@pulp-v1-server ~]# 
[server]
server_name: pulp-v1-server.usersys.redhat.com
relative_url: /pulp/repos
key_url: /pulp/gpg
ks_url: /pulp/ks
default_login: admin
default_password: admin
post_sync_url: https://localhost/pulp/api/sync/post_action
[root@pulp-v1-server ~]#  pulp-admin repo create --id zoo --feed http://inecas.fedorapeople.org/fakerepos/zoo/ --relativepath zoo
Successfully created repository [ zoo ]

[root@pulp-v1-server ~]# pulp-admin repo sync --id=zoo --interval=PT5M --start=2012-02-07T12:40:00-01:00:00
Sync schedule for repo [ zoo ] changed to [ 2012-02-07T12:40:00-01:00/PT5M ]
[root@pulp-v1-server ~]# 
[root@pulp-v1-server ~]# 


ssl_access_log

10.16.120.248 - - [04/Apr/2012:08:40:09 -0400] "PUT /pulp/api//repositories/zoo/schedules/sync/ HTTP/1.1" 200 123
::1 - - [04/Apr/2012:08:45:10 -0400] "POST /pulp/api/sync/post_action HTTP/1.1" 404 9
::1 - - [04/Apr/2012:08:50:06 -0400] "POST /pulp/api/sync/post_action HTTP/1.1" 404 9
Comment 7 Preethi Thomas 2012-05-25 10:16:13 EDT
Pulp v1.1 Release

Note You need to log in before you can comment on or make changes to this bug.