Bug 809202 - bwbar not starting up properly, something is wrong with systemd service
bwbar not starting up properly, something is wrong with systemd service
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: bwbar (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adrian Reber
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-02 14:02 EDT by Jonathan Kamens
Modified: 2012-08-24 08:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-24 08:16:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2012-04-02 14:02:46 EDT
Apr  1 14:23:33 jik2 bwbar[1210]: Usage: /usr/bin/bwbar [options] interface max_mbps
Apr  1 14:23:33 jik2 bwbar[1210]: Options: (defaults in parenthesis)
Apr  1 14:23:33 jik2 bwbar[1210]: --input               -i   Measure input bandwidth
Apr  1 14:23:33 jik2 bwbar[1210]: --output              -o   Measure output bandwidth (default)
Apr  1 14:23:33 jik2 bwbar[1210]: --directory           -d   Output directory
Apr  1 14:23:33 jik2 bwbar[1210]: --text-file <file>    -f   The name of the text output file (ubar.txt)
Apr  1 14:23:33 jik2 bwbar[1210]: --png-file <file>     -p   The name of the graphical bar file (ubar.png)
Apr  1 14:23:33 jik2 bwbar[1210]: --interval <seconds>  -t   The poll interval in seconds (15)
Apr  1 14:23:33 jik2 bwbar[1210]: --width <pixels>      -x   Width of the graphical bar (600)
Apr  1 14:23:33 jik2 bwbar[1210]: --height <pixels>     -y   Height of the graphical bar (4)
Apr  1 14:23:33 jik2 bwbar[1210]: --border <pixels>     -b   Border width of the graphical bar (1)
Apr  1 14:23:33 jik2 bwbar[1210]: --kbps                -k   Bandwidth is measured in kbit/s
Apr  1 14:23:33 jik2 bwbar[1210]: --Mbps                -M   Bandwidth is measured in Mbit/s (default)
Apr  1 14:23:33 jik2 bwbar[1210]: --Gbps                -G   Bandwidth is measured in Gbit/s
Apr  1 14:23:33 jik2 bwbar[1210]: --help                -h   Display this text
Apr  1 14:23:33 jik2 systemd[1]: bwbar.service: main process exited, code=exited, status=1
Apr  1 14:23:33 jik2 systemd[1]: Unit bwbar.service entered failed state.
Comment 1 Jonathan Kamens 2012-04-02 14:04:25 EDT
Also there's a typo in the usage message. It should say "defaults in parentheses" instead of "defaults in parenthesis".
Comment 2 Adrian Reber 2012-04-02 14:13:06 EDT
Can you specify the exact version of bwbar.
Comment 3 Jonathan Kamens 2012-04-02 14:19:28 EDT
bwbar-1.2.3-11.fc17.x86_64
Comment 4 Adrian Reber 2012-04-02 14:26:22 EDT
Do you have a /etc/sysconfig/bwbar file? What is the content?
Comment 5 Jonathan Kamens 2012-04-02 14:28:59 EDT
Just this:

#OPTIONS="eth0 100 -d /path/to/outdir"

I haven't done anything to this package except install it.
Comment 6 Adrian Reber 2012-04-02 15:18:41 EDT
Okay. Not sure what the correct approach is. You need to edit this file to adapt it to your needs: configure the output directory; configure your available bandwidth.

So I would say it is not really a bug. Not sure. Do you think it should work from the installation with default values?
Comment 7 Jonathan Kamens 2012-04-02 16:40:20 EDT
Either it needs to have sensible default values that work out-of-the-fox, or the service needs to be disabled by default. Then users can enable it after putting appropriate options in /etc/sysconfig/bwbar. If you go this route, then you might want to put a comment in that file telling people to enable the service after editing it.
Comment 8 Adrian Reber 2012-04-03 04:27:28 EDT
Are you sure it is enable by default. From what I understand from systemd (not much) it seems to be off.
Comment 9 Jonathan Kamens 2012-04-03 08:41:25 EDT
As I said, I didn't do anything with this package but install it.

I could be wrong, but it seems to me that "WantedBy=multi-user.target" in /lib/systemd/system/bwbar.service would cause it to be enabled by default upon installation.
Comment 10 Adrian Reber 2012-08-24 08:16:15 EDT
Closing it as WORKSFORME. I tried a few more installation and was never able to reproduce it. There is nothing in the specfile which should enable it by default.

Note You need to log in before you can comment on or make changes to this bug.