Bug 809222 - Set server identity (-i) through sysconfig file
Set server identity (-i) through sysconfig file
Status: CLOSED WONTFIX
Product: Fedora EPEL
Classification: Fedora
Component: varnish (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Ingvar Hagelund
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-02 15:05 EDT by George Notaras
Modified: 2013-11-06 09:36 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-06 09:36:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Notaras 2012-04-02 15:05:56 EDT
Since each varnish server could be part of a server farm, it would be nice if /etc/sysconfig/varnish had a user-definable variable, ``VARNISH_IDENTITY``, which would then be used in the ``-i`` command line option of varnishd.

When ``-i`` is used, the identity string is available in the vcl as the ``server.identity`` variable and could be used to form special informative headers about the server that served the request.
Comment 1 Ingvar Hagelund 2013-11-06 09:36:53 EST
This would be a change for upstream. I don't think I'll add this to the EPEL package at this point. 

It is quite trivial to add configuration that adds this by hand anyway. Just add the necessary options to DAEMON_OPTS in /etc/sysconfig/varnish.

Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.