Bug 80923 - EAPI_MM_CORE_PATH in "spec" file broken
EAPI_MM_CORE_PATH in "spec" file broken
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
7.3
All Linux
medium Severity high
: ---
: ---
Assigned To: Joe Orton
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-02 08:29 EST by Michiel Toneman
Modified: 2007-04-18 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 06:27:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michiel Toneman 2003-01-02 08:29:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

Description of problem:
Setting the EAPI_MM_CORE_PATH variable in apache.spec should override the
default path of "/var/run" for file based semaphores. 

Now that we've gone back to file based semaphores instead of kernel semaphores
we're once again stuck with an apache which cannot be started as non-root user.
The "elegant hack" is to change the EAPI_MM_CORE_PATH in the apache source RPM
and rebuild.

This setting does not work anymore, however, and the default "/var/run" path is
used regardless. The only workaround I have now is to patch the httpd binary and
change the string "/var/run/httpd.mm" to "/var/rub/httpd.mm" and make a
directory /var/rub (chmod 1777).



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run httpd as non root user

Actual Results:  Ouch! ap_mm_create(1048576, "/var/run/httpd.mm.1344") failed
Error: MM: mm:core: failed to open semaphore file (Permission denied): OS: No
such file or directory


Expected Results:  httpd should start

Additional info:

The updated mm package in RHBA-2002:273
https://rhn.redhat.com/network/errata/details/index.pxt?eid=1355

Also see:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=77703
Comment 1 Joe Orton 2003-01-16 12:30:59 EST
Appreciate the new bug since the bug has re-appeared, this is really the same
bug as 77703 though as you say.

*** This bug has been marked as a duplicate of 77703 ***
Comment 2 Michiel Toneman 2003-01-17 05:30:12 EST
Hi Joe,

Unfortunately this is *not* a duplicate of 77703. This bug is about the fact
that the EAPI_MM_CORE_PATH directive is no longer honored, so a SRPM recompile
no longer works to override the path (in apache-1.3.27-2).

I've now resorted to patching the apache binary :'(

Comment 3 Joe Orton 2004-09-21 06:27:29 EDT
Thanks for the report.  This bug is no longer present in the Apache
httpd 2.0 packages in Red Hat Enterprise Linux and Fedora Core.

Note You need to log in before you can comment on or make changes to this bug.