Bug 809276 - Evolution email display lockup
Evolution email display lockup
Status: CLOSED DUPLICATE of bug 808319
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
16
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-02 19:24 EDT by John Mellor
Modified: 2012-04-03 21:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-03 21:25:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Typical email causing Evolution message display lockup (18.10 KB, application/mbox)
2012-04-02 19:24 EDT, John Mellor
no flags Details

  None (edit)
Description John Mellor 2012-04-02 19:24:07 EDT
Created attachment 574678 [details]
Typical email causing Evolution message display lockup

Description of problem:
Attached typical message locks up Evolution display


Version-Release number of selected component (if applicable):
3.2.3

How reproducible:
Every time, with the attached email (saved in mbox format).

Steps to Reproduce:
1. Start evolution.  Get email from upstream (mine comes from 2 pop sources)
2. Read emails.  When you get to this one (typical, one comes every day like it), it partially displays, and disables further email displays in preview or mail pop-out.
3. Quit.  Restart evolution.  Note that the same behaviour is 100% repeatable for the current message.
4. Delete the fault-causing message.  Note that the message content display is locked up.
5. Quit Evolution.  Restart Evolution.
6. Note that with the fatal message deleted, all other emails can be normally read and handled.  Poor workaround.
  
Actual results:
Evolution preview and/or message display window panes are locked up after reading the offending typical message.

Expected results:
Evolution does not lockup under any conditions.

Additional info:
This is a tracking bug.  Also filed at https://bugzilla.gnome.org/show_bug.cgi?id=673393
Up-to-date Fedora 16 untainted, using AMD processor and the normal ATI open-source driver.  System is very stable other than this bug.
Comment 1 Milan Crha 2012-04-03 02:50:04 EDT
Thanks for a bug report. It'll be good to not duplicate the work, both for you and for me. Things which are not fedora related (which is sometimes hard do decide) are usually treated upstream, instead of here.

Anyway, can this be the same issue as in bug #808319, please?
Comment 2 John Mellor 2012-04-03 21:24:51 EDT
Yup, the workaround posted in bug #808319 seems to work.
Comment 3 John Mellor 2012-04-03 21:25:13 EDT

*** This bug has been marked as a duplicate of bug 808319 ***

Note You need to log in before you can comment on or make changes to this bug.