This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 809279 - KDE Battery Monitor reports two batteries instead of existing one after update to kernel 3.3
KDE Battery Monitor reports two batteries instead of existing one after updat...
Status: CLOSED DUPLICATE of bug 806295
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-02 19:48 EDT by vitor.dominor
Modified: 2012-04-04 05:14 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-04 05:14:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vitor.dominor 2012-04-02 19:48:27 EDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0

After updating the kernel to 3.3.0-8 version, the kde battery monitor reports two batteries instead of the one that really exists, meaning another one in addition to the real battery. The charge level of the real battery is correct as well as whether the laptop is connected to AC or not or charging, but the second fake battery is always reported as discharging. If I go back to the 3.2 kernel, battery info is correctly reported.

Reproducible: Always




Running Fedora 16 KDE Spin with KDE 4.8.1.
Comment 1 Kevin Kofler 2012-04-02 19:55:31 EDT
The kernel was what was upgraded when the bug sprang up, so I'd blame the kernel first of all. Plasma can only report what upower reports, and upower can only report what the kernel reports.
Comment 2 Rex Dieter 2012-04-02 20:08:25 EDT
Output of:
udisks --enumerate
(ideally before and after up'ing kernel to 3.3) may help give a clue
Comment 3 Radek Novacek 2012-04-03 02:10:35 EDT
I think Rex meant
upower --enumerate
Comment 4 vitor.dominor 2012-04-03 20:03:25 EDT
The kernel was not the only component upgraded at the time, however if I change back to a previous kernel like 3.2.10 (which I have installed alongside the 3.3.0 kernel), then the issue doesn't happen, only in 3.3.0.
The following is the output of upower --enumerate in 
kernel 3.2.10
$ upower --enumerate
/org/freedesktop/UPower/devices/line_power_ACAD
/org/freedesktop/UPower/devices/battery_BAT0

and
kernel 3.3.0
$ upower --enumerate

/org/freedesktop/UPower/devices/line_power_ACAD
/org/freedesktop/UPower/devices/battery_BAT0
/org/freedesktop/UPower/devices/battery_hid_00o02o76o23o15o78_battery.
Comment 5 Rex Dieter 2012-04-03 20:58:41 EDT
ok, next when in 3.3.0, 

upower --show-info \
/org/freedesktop/UPower/devices/battery_hid_00o02o76o23o15o78_battery
Comment 6 vitor.dominor 2012-04-03 21:27:03 EDT
Output of:
$ upower --show-info \
/org/freedesktop/UPower/devices/battery_hid_00o02o76o23o15o78_battery
  native-path:          /sys/devices/pci0000:00/0000:00:1d.2/usb7/7-2/7-2:1.0/bluetooth/hci0/hci0:11/0005:1048:03ED.0001/power_supply/hid-00:02:76:23:15:78-battery
  model:                Targus Soft-Touch Bluetooth Mouse
  power supply:         yes
  updated:              Wed Apr  4 02:11:22 2012 (30 seconds ago)
  has history:          yes
  has statistics:       yes
  battery
    present:             yes
    rechargeable:        yes
    state:               discharging
    energy:              0 Wh
    energy-empty:        0 Wh
    energy-full:         0 Wh
    energy-full-design:  0 Wh
    energy-rate:         0 W
    percentage:          17%
    capacity:            100%
  History (charge):
    1333501848  17.000  discharging
    1333501848  0.000   unknown
  History (rate):
    1333501848  0.000   unknown

Surprise (at least to me)! It's referring to the batteries of my bluetooth mouse. Interestingly, Windows 7 is capable of detecting the battery level of my bluetooth mouse. Nonetheless, it is a separate figure from the battery level of the battery of the laptop. If it's a new feature of KDE 4.8, I'm pleased to see that KDE is now capable of reporting this, but still it would be better to report it separately somehow. Right now it is treated as one more battery in the computer by the kde battery monitor.
Comment 7 vitor.dominor 2012-04-03 21:34:07 EDT
With this new piece of information, I think this bug is surely related if not duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=806295.
Comment 8 Kevin Kofler 2012-04-04 05:14:18 EDT
Yes, it's the same bug.

*** This bug has been marked as a duplicate of bug 806295 ***

Note You need to log in before you can comment on or make changes to this bug.