Bug 80935 - TB NCHardwareFactory.py:42:getHardwareClass: KeyError: Wireless
TB NCHardwareFactory.py:42:getHardwareClass: KeyError: Wireless
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: redhat-config-network (Show other bugs)
beta3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 80991 81090 81626 (view as bug list)
Depends On:
Blocks: 79578 81720
  Show dependency treegraph
 
Reported: 2003-01-02 11:03 EST by Nitin Dahyabhai
Modified: 2008-05-01 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-04 11:08:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
stack dump, generated by "Save to File" option on crash (1.68 KB, text/plain)
2003-01-02 11:04 EST, Nitin Dahyabhai
no flags Details
stack dump, generated by "Save to File" option on crash (2.11 KB, text/plain)
2003-01-14 10:46 EST, Nitin Dahyabhai
no flags Details

  None (edit)
Description Nitin Dahyabhai 2003-01-02 11:03:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20021223

Description of problem:
On a fresh installation (not an upgrade) of Phoebe redhat-config-network crashes
whenever my Sony PCWA-C150S (16-bit) wireless PCMCIA card is inserted. I'm
including the crash dump as an attachment.  It happens consistently when trying
to launch the tool and only when the wireless card is in.  Both the card and
tool worked properly in Psyche.

How reproducible:
Always

Steps to Reproduce:
1. Boot up normally and log in.
2. Insert wireless PCMCIA card
3. Attempt to launch redhat-config-network
Comment 1 Nitin Dahyabhai 2003-01-02 11:04:53 EST
Created attachment 89057 [details]
stack dump, generated by "Save to File" option on crash
Comment 2 Nitin Dahyabhai 2003-01-02 11:14:37 EST
Also worked correctly in 8.0.91 release.
Comment 3 Harald Hoyer 2003-01-08 12:13:51 EST
*** Bug 81090 has been marked as a duplicate of this bug. ***
Comment 4 Harald Hoyer 2003-01-09 08:39:38 EST
*** Bug 80991 has been marked as a duplicate of this bug. ***
Comment 5 Harald Hoyer 2003-01-13 06:07:23 EST
*** Bug 81626 has been marked as a duplicate of this bug. ***
Comment 6 Harald Hoyer 2003-01-13 08:38:05 EST
will be fixed in versions >= 1.1.87
Comment 7 Harald Hoyer 2003-01-13 10:18:56 EST
new packages to test available at:
ftp://people.redhat.com/harald/redhat-config-network/1.1.87-1/
ftp://people.redhat.com/harald/rhpl/0.74-2/
Comment 8 Nitin Dahyabhai 2003-01-14 10:46:14 EST
Created attachment 89352 [details]
stack dump, generated by "Save to File" option on crash

Created by launching redhat-config-network after installing rhpl-0.74-2 and
redhat-config-network-1.1.87-1
Comment 9 Jay Turner 2003-01-21 09:22:26 EST
Putting this back in Assigned, as there still appears to be a problem.
Comment 10 Harald Hoyer 2003-01-21 09:26:44 EST
i thought 1.1.90 fixed this...
Comment 11 Nitin Dahyabhai 2003-01-21 12:14:24 EST
It was broken (differently) in 1.1.87-1, but yes, everything seems to work in 1.1.90

Note You need to log in before you can comment on or make changes to this bug.