Bug 809356 - libvirt-qmf runs as initrc_t
libvirt-qmf runs as initrc_t
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.3
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks: 832330
  Show dependency treegraph
 
Reported: 2012-04-03 03:54 EDT by Milos Malik
Modified: 2012-10-15 11:17 EDT (History)
1 user (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-146.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:32:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2012-04-03 03:54:35 EDT
Description of problem:


Version-Release number of selected component (if applicable):
selinux-policy-doc-3.7.19-143.el6.noarch
selinux-policy-3.7.19-143.el6.noarch
selinux-policy-mls-3.7.19-143.el6.noarch
selinux-policy-minimum-3.7.19-143.el6.noarch
selinux-policy-targeted-3.7.19-143.el6.noarch
libvirt-qmf-0.3.0-5.el6.x86_64

How reproducible:
always

Steps to Reproduce:
# run_init service libvirt-qmf status
Authenticating root.
Password: 
libvirt-qmf is stopped
# run_init service libvirt-qmf start
Authenticating root.
Password: 
Starting the libvirt-qmf daemon:                           [  OK  ]
# ps -efZ | grep initrc
system_u:system_r:initrc_t:s0   root      9511     1  0 09:53 ?        00:00:00 libvirt-qmf --broker 127.0.0.1 --daemon --reconnect=yes
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 root 9516 9435  0 09:53 pts/0 00:00:00 grep initrc
# 
  
Actual results:
* libvirt-qmf runs as initrc_t

Expected results:
* libvirt-qmf runs in its own SELinux domain
Comment 1 Miroslav Grepl 2012-04-03 04:08:24 EDT
We have this policy in Fedora, should be backported.
Comment 11 errata-xmlrpc 2012-06-20 08:32:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0780.html

Note You need to log in before you can comment on or make changes to this bug.