Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 809407 - [RFE] Admin of the org can't create users/permissions of his own organization
Summary: [RFE] Admin of the org can't create users/permissions of his own organization
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: Unspecified
Assignee: Jason E. Rist
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-03 09:45 UTC by Garik Khachikyan
Modified: 2015-01-04 21:59 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-09 17:31:10 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Garik Khachikyan 2012-04-03 09:45:19 UTC
Description of problem:
Preparing admin (all) permission for the org and assigning an "org_admin" user to that perm. still not enables for that "admin" to prepare users & permissions setup for that local Org (the section in UI is hidden and available for the real admin-superadmin only).

Version-Release number of selected component (if applicable):
Recent Katello impl.
candlepin-0.5.26-1.el6.noarch
pulp-common-1.0.0-8.el6.noarch
candlepin-tomcat6-0.5.26-1.el6.noarch
katello-glue-foreman-0.2.24-1.git.5.fbbb981.el6.noarch
katello-0.2.24-1.git.5.fbbb981.el6.noarch
katello-repos-testing-0.2.1-1.el6.noarch
katello-configure-0.2.17-1.git.0.3e1bb5b.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
mod_wsgi-3.3-3.pulp.el6.x86_64
katello-common-0.2.24-1.git.5.fbbb981.el6.noarch
katello-selinux-0.2.4-1.git.0.b03a73e.el6.noarch
qpid-cpp-server-ssl-0.12-6.el6.x86_64
python-qpid-0.12-1.el6.noarch
katello-certs-tools-1.1.5-1.git.0.f153109.el6.noarch
qpid-cpp-server-0.12-6.el6.x86_64
katello-glue-pulp-0.2.24-1.git.5.fbbb981.el6.noarch
pulp-1.0.0-8.el6.noarch
qpid-cpp-client-ssl-0.12-6.el6.x86_64
katello-qpid-broker-key-pair-1.0-1.noarch
katello-cli-common-0.2.20-1.git.0.2babcce.el6.noarch
katello-cli-0.2.20-1.git.0.2babcce.el6.noarch
m2crypto-0.21.1.pulp-7.el6.x86_64
python-oauth2-1.5.170-2.pulp.el6.noarch
qpid-cpp-client-0.12-6.el6.x86_64
katello-glue-candlepin-0.2.24-1.git.5.fbbb981.el6.noarch
katello-repos-0.2.1-1.el6.noarch
pulp-selinux-server-1.0.0-8.el6.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-agent-1.0.3-1.git.0.cccd0b4.el6.noarch
katello-cli-tests-0.2.9-1.git.0.68eeea8.el6.noarch

How reproducible:
always

Steps to Reproduce:
-create an org - org1
-create and env for that org
-add user selecting the default org: org1
-create user role: ur_org1Admin
-create permission for that role: perm_org1Admin and specify "all" for the org1
-assign that user to that permission
-logout "admin" and login by that user
-try to add a user for that org1
  
Actual results:
not possible

Expected results:
an Org admin should be able to handle creating users / permissions of his own org there.

Additional info:

Comment 1 Garik Khachikyan 2012-04-03 09:51:02 UTC
CLI restricts there as well:
---
User org1_admin is not allowed to access api/users/create

Comment 3 Mike McCune 2012-04-09 17:30:34 UTC
it is as Partha states.  Users don't exist *within* single orgs, they exist on a level higher than the org itself and are granted access to one or more orgs.  

granting a user org_admin means they can manage orgs themselves but having the ability to create/remove users is greater access then managing orgs.

Comment 5 Mike McCune 2013-08-16 18:05:31 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.