Bug 809466 - libreoffice-core (unintentionally) provides libraptor.so.1()() and librdf.so.0()()
Summary: libreoffice-core (unintentionally) provides libraptor.so.1()() and librdf.so....
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libreoffice
Version: 6.3
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: rc
: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-03 12:51 UTC by Tomas Pelka
Modified: 2012-06-20 12:53 UTC (History)
6 users (show)

Fixed In Version: libreoffice-3.4.5.2-13.el6
Doc Type: Enhancement
Doc Text:
No Documentation needed
Clone Of:
Environment:
Last Closed: 2012-06-20 12:53:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0798 normal SHIPPED_LIVE new packages: libreoffice 2012-06-19 21:00:52 UTC

Description Tomas Pelka 2012-04-03 12:51:29 UTC
Description of problem:
Because of libreoffice incrusion into ComputeNode we need to add mythes-*.noarch, hyphen-*.noarch and hunspell-*.noarch packages into Computenode chanell.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 3 David Tardon 2012-04-09 15:49:44 UTC
We build with internal raptor, because the system one is not usable for us (comment in configure.in says: "versions before 1.0.8 write RDF/XML that is useless for ODF (@xml:base)"). The Provides are generated by rpmbuild; I do not know what can be done about that.

dtardon->jnovy: Is there a way to filter the generated Provides list?

Comment 4 David Tardon 2012-04-09 17:45:07 UTC
I suppose that we could just change the redland libraries' names, e.g., add a 'lo' suffix. That would require (small) change in 3 or 4 source files, which is IMHO quite manageable...

Comment 5 Jindrich Novy 2012-04-10 06:20:34 UTC
+1 for changing the provides instead of filtering them.

Comment 6 Caolan McNamara 2012-04-11 15:20:20 UTC
dgregor said "I'll manually filter libreoffice from ComputeNode for the beta", so that part of urgent is taken care of.

caolanm->dtardon: want to have a shot at it. Disabling AutoProvides and doing that manually is real painful. Fridrich was talking about trying to do custom sonames for all the "external" libraries we have to to bundle upstream.

Same problem exists for e.g. xmlsec and other stuff we have to bundle downstream.

Comment 7 David Tardon 2012-04-13 08:29:15 UTC
Done for redland libs. There is actually no problem with libxmlsec and mythes, because we build them as static archives.

dtardon->caolanm: fixed in F-16, as usual.

Comment 8 Caolan McNamara 2012-04-13 11:00:40 UTC
ah, indeed.

Comment 11 Caolan McNamara 2012-05-01 09:04:53 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No Documentation needed

Comment 14 errata-xmlrpc 2012-06-20 12:53:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0798.html


Note You need to log in before you can comment on or make changes to this bug.