Bug 809496 - Release version: drop-down remains disabled after subscribing to RHEL
Release version: drop-down remains disabled after subscribing to RHEL
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Adrian Likins
Entitlement Bugs
:
Depends On:
Blocks: 738066 834012 834013
  Show dependency treegraph
 
Reported: 2012-04-03 10:19 EDT by John Sefler
Modified: 2012-06-20 11:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:08:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The Release version drop-down list in GUI should match the CLI release --list (75.65 KB, image/png)
2012-04-03 10:19 EDT, John Sefler
no flags Details

  None (edit)
Description John Sefler 2012-04-03 10:19:27 EDT
Created attachment 574878 [details]
The Release version drop-down list in GUI should match the CLI release --list

Description of problem:
After subscribing to the RHEL subscription, the new Release version setting in the System Preferences dialog remains disabled.  See attached screenshot. 


Version-Release number of selected component (if applicable):
[root@jsefler-r63-workstation ~]# rpm -q subscription-manager-gnome
subscription-manager-gnome-0.99.12-1.git.15.a46d527.el6.x86_64


How reproducible:


Steps to Reproduce:
1. Using the GUI and the stage environment, register as stage_test_12 (if on server) or stage_test_27 (if on workstation) and subscribe to the RHEL subscription.
2. on the CLI run...
[root@jsefler-r63-workstation ~]# subscription-manager release --list
5.7
5.8
5Client
6.0
6.1
6.2
6Workstation

3. In the GUI, click the toollbar button for System Preferences and the Release version dropdown menu should list the same values as the CLI, but it remains disabled.
Comment 1 Adrian Likins 2012-04-03 12:23:40 EDT
I think this is an artifact of stage not supporting releasever yet. We don't
enable the dropdown if we can't get/set releaseVer, even though we
could populate the list from the CDN.

Look for warnings like:


2012-04-03 12:25:47,892 [WARNING]  @preferences.py:99 - Disabling release version  dropdown, server does not support release versions.
2012-04-03 12:25:47,893 [WARNING]  @preferences.py:78 - Disabling service level dropdown, server does not support service levels.

logged in rhsm.log
Comment 3 spandey 2012-04-10 06:27:00 EDT
As per comment 1 verifying defect using following rpm 

subscription-manager-0.99.13-1.el6.x86_64
subscription-manager-migration-0.99.13-1.el6.x86_64
subscription-manager-firstboot-0.99.13-1.el6.x86_64
subscription-manager-gnome-0.99.13-1.el6.x86_64

Got following message in rhsm.log 

ription/consumers/3bb091c8-9aef-4d8f-87d6-0722eacb7015
2012-04-10 16:26:36,689 [DEBUG]  @connection.py:343 - Response status: 200
2012-04-10 16:26:36,689 [WARNING]  @preferences.py:98 - Disabling release version  dropdown, server does not support release versions.
2012-04-10 16:26:36,690 [WARNING]  @preferences.py:78 - Disabling service level dropdown, server does not support service levels.



Resolving defect as verified
Comment 5 errata-xmlrpc 2012-06-20 09:08:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.