Bug 809499 - improve anaconda launcher description
improve anaconda launcher description
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-03 10:26 EDT by Kamil Páral
Modified: 2012-10-23 17:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 11:54:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2012-04-03 10:26:53 EDT
Description of problem:
By default anaconda launcher on LiveCD has name "Install to Hard Drive" (displayed as a tooltip in Gnome Shell Overview). Several people noted that "hard drive" term is becoming obsolete, because we can install to thumb drives, SSDs, etc. They proposed changing the name to "Install Fedora" and I agree it's better. Thus proposing here as an enhancement.

We should probably also change the description.

Current state:
$ cat /usr/share/applications/liveinst.desktop
Name=Install to Hard Drive
Comment=Install the live CD to your hard disk

Proposal:
Name=Install Fedora
Comment=Install Fedora onto this machine

(English correction might be needed.)

Version-Release number of selected component (if applicable):
F17 Beta RC2
Comment 1 Chris Lumens 2012-05-14 10:31:59 EDT
With the new welcome screen in the live installer, do you think this bug report is still valid?
Comment 2 Kamil Páral 2012-05-14 11:00:07 EDT
I think it still makes sense to rename the launcher. It is shown in GNOME dash, installed applications list and also in all non-GNOME desktops. "Install Fedora" would be nice. OTOH I understand that can cause you some troubles, because you'd need to patch it for RHEL install media.
Comment 3 Brian Lane 2012-07-18 17:57:25 EDT
What about the cases where non-Fedora distributions want to use Anaconda?

Really, I don't think Anaconda should own that file at all, it should come from the spin so that they can customize it as they see fit.
Comment 4 Brian Lane 2012-10-23 11:54:47 EDT
The new 'Welcome to Fedora' also says 'Install to Hard Drive' so we're being consistent.
Comment 5 Kamil Páral 2012-10-23 17:27:09 EDT
It was created to mirror Anaconda's launcher name, and the welcome screen is now even in your code base, but hey.

Note You need to log in before you can comment on or make changes to this bug.