Bug 809521 - EPP-SP: Content language is incorrectly set to 'uk' when user language is set to <language>_<country> like pt_BR
EPP-SP: Content language is incorrectly set to 'uk' when user language is set...
Status: NEW
Product: JBoss Enterprise Portal Platform 5
Classification: JBoss
Component: Site Publisher (Show other bugs)
5.2.0.GA,5.2.0.SP.GA
Unspecified Unspecified
unspecified Severity high
: ---
: 5.2.x
Assigned To: Default User
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-03 11:03 EDT by Martin Weiler
Modified: 2012-04-11 19:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When using SitePublisher with a language defined by <language>_<country> (such as Brazillian Portuguese: pt_BR), the drop down fields to select the content language is not automatically set to this language. Instead, the first language in the list - 'uk' - is auto-selected. A fix is currently being investigated.
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
EXO WCM JIRA SPREDHAT-137 None None None Never

  None (edit)
Description Martin Weiler 2012-04-03 11:03:43 EDT
Description of problem:
Create a new site, set it to Portugues (Brasil), add a free layout web content, the idiom field is automatically set to uk, instead to pt_BR.


How reproducible:
always

Steps to Reproduce:
1. Start EPP 5.2.0 + SP
2. Log in as root
3. Change language to pt_BR
4. Content Explorer -> Add document -> (any type with language), eg. Free layout webcontent
5. Language field is auto-selected to 'uk'
If users language is set to a language only defined by <language>, such as de or fr, pre-selection of language field works..
Comment 1 Martin Weiler 2012-04-11 06:04:20 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
When using SitePublisher with a language defined by <language>_<country> (such as Brasilian Portuguese: pt_BR), the drop down fields to select the content language is not automatically set to this language. Instead, the first language in the list - 'uk' - is auto-selected. A fix is currently being investigated.
Comment 2 Jared MORGAN 2012-04-11 19:21:43 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-When using SitePublisher with a language defined by <language>_<country> (such as Brasilian Portuguese: pt_BR), the drop down fields to select the content language is not automatically set to this language. Instead, the first language in the list - 'uk' - is auto-selected. A fix is currently being investigated.+When using SitePublisher with a language defined by  &lt;language&gt;_&lt;country&gt; (such as Brazillian Portuguese: pt_BR), the drop down fields to select the content language is not automatically set to this language. Instead, the first language in the list - 'uk' - is auto-selected. A fix is currently being investigated.

Note You need to log in before you can comment on or make changes to this bug.