Bug 809534 - system-config-network ignores option field
system-config-network ignores option field
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: system-config-network (Show other bugs)
6.2
s390x Linux
medium Severity medium
: beta
: 6.6
Assigned To: Harald Hoyer
qe-baseos-daemons
:
Depends On:
Blocks: 1004793
  Show dependency treegraph
 
Reported: 2012-04-03 11:29 EDT by Lee
Modified: 2014-07-24 09:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-24 09:17:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 89152 None None None Never

  None (edit)
Description Lee 2012-04-03 11:29:35 EDT
Description of problem:
Installed RHEL 6.2 under z/VM using a Layer 3 Vswitch.  User went to change the IP address using system-config-network.  File /etc/sysconfig/networking/devices/ifcfg-eth0 contained a record 
OPTIONS="layer2=0"
before running system-config-network, but the OPTIONS record was missing after running it.

That caused eth0 activation to fail because it was trying to establish a Layer 2 connection that the Vswitch did  not allow.

Version-Release number of selected component (if applicable):


How reproducible:
Invoke system-config-network against an interface with options in the ifcfg-eth0 file.  Make any change (IP address in our case).  Save your changes.  Options record now absent.


Steps to Reproduce:
1.  Invoke system-config-network against an interface with options in the ifcfg-eth0 file.
2.  Make any change (IP address in our case).
3.  Save your changes.
4.  Options record now absent
  
Actual results:
OPTIONS="layer2=0" record missing from both the display panel and the ifcfg-eth0 file.

Expected results:
The options value would be displayed in the panel for the user to see and/or change, and existing options would be written to the ifcfg-eth0 file.

Additional info:
Comment 2 RHEL Product and Program Management 2012-07-10 04:36:39 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2012-07-10 21:51:02 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 4 RHEL Product and Program Management 2012-08-14 18:00:21 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 5 RHEL Product and Program Management 2012-12-14 03:33:48 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 IBM Bug Proxy 2013-02-27 11:01:08 EST
reverse mirror
Comment 7 IBM Bug Proxy 2013-03-06 00:30:42 EST
I tried this on RHEL6.4 GA.

Using system-config-network  I tried to create config file for OSA qeth device in Layer2 mode.

After checking the ifcfg-ethx file created , I see that OPTIONS field value (Layer2=1) that I had provided in system-config-network tool is missing in the created ifcfg-ethx file.

Also the MAC address provided in system-config-network file was also missing from the config file.
Comment 9 RHEL Product and Program Management 2013-10-13 20:43:57 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 10 IBM Bug Proxy 2014-06-30 01:56:59 EDT
------- Comment From baude@us.ibm.com 2013-02-27 15:53 EDT-------

------- Comment From htengshe@in.ibm.com 2013-03-06 05:29 EDT-------
Comment 11 IBM Bug Proxy 2014-07-24 09:02:01 EDT
------- Comment From hannsj_uhl@de.ibm.com 2014-07-24 12:57 EDT-------
fyi .. IBM is not pursuing this bugzilla .. bugzilla can be closed ...

Note You need to log in before you can comment on or make changes to this bug.