Bug 809537 - info test kernel validation should allow more flexibility to support beta testing.
info test kernel validation should allow more flexibility to support beta tes...
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
1.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Caspar Zhang
:
Depends On:
Blocks: 767775
  Show dependency treegraph
 
Reported: 2012-04-03 11:32 EDT by Greg Nichols
Modified: 2013-07-03 03:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no tech note needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 17:37:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
info test patch to allow partial matches of version-release string (1.21 KB, patch)
2012-04-03 11:35 EDT, Greg Nichols
no flags Details | Diff
kernel info file adding 6.3 mapping to "2.6.32-" (447 bytes, patch)
2012-04-03 11:53 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Greg Nichols 2012-04-03 11:32:18 EDT
Description of problem:

The new info test in v7 1.5 validates the tested kernel against a table of RHEL GA kernel versions to insure the SUT is running a GA kernel.   In RHEL/v7 beta, this test will always fail, as the GA kernel version is not yet known during beta.

v7's info test should allow partial matches of the version-release string during beta.  for example, if the validation file contains "2.6.32" it should match "2.6.32-220".

This will allow the validation file (/usr/share/v7/lib/v7/kernelInfo.xml) to specify a range of kernel versions during beta.   When the RHEL GA kernel is known, the updated copy v7 attempts to download can be fixed to a specific version-release.
Comment 1 Greg Nichols 2012-04-03 11:35:08 EDT
Created attachment 574900 [details]
info test patch to allow partial matches of version-release string
Comment 2 Greg Nichols 2012-04-03 11:53:37 EDT
Created attachment 574904 [details]
kernel info file adding 6.3 mapping to "2.6.32-"
Comment 6 Caspar Zhang 2012-06-04 04:01:31 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
no tech note needed.
Comment 8 errata-xmlrpc 2012-06-05 17:37:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0711.html

Note You need to log in before you can comment on or make changes to this bug.