Bug 809558 - touchpad pointer movement nearly unusable
touchpad pointer movement nearly unusable
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: synaptics (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-03 12:18 EDT by Marcus Moeller
Modified: 2012-04-04 04:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-04 04:35:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcus Moeller 2012-04-03 12:18:32 EDT
Description of problem:
With the latest synaptics package, it is now very difficult to do small movements (e.g. for clicking a small icon or link), because the pointer keeps on moving while the finger rests on the touchpad.

This is shows in synclient:
$ synclient
...
    CoastingSpeed           = 0
    CoastingFriction        = 50
   PressureMotionMinZ      = format mismatch (32)
   PressureMotionMaxZ      = format mismatch (32)
    PressureMotionMinFactor = 0
    PressureMotionMaxFactor = 0
...

Notice the error with the PressureMotion settings.

Version-Release number of selected component (if applicable):
xorg-x11-drv-synaptics-1.5.99-7.20120207git141d9120b

Apparently a new type of properties was introduced, called cardinals.
These do not (yet) seem to be supported by synclient and xinput.

See this patch proposed in June:
http://lists.x.org/archives/xorg-devel/2011-June/023284.html
or in git:
http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/diff/?id2=6269fdaf3283ba4a8051858fc2b43fa102823e96
and
http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/commit/?id=a24c44375025576dd600ccf370ba365e5d94dc22

Which would explain the error I see in xinput:
Synaptics Pressure Motion (292):		... of unknown type CARDINAL
which may just be the meaning of "32" in synclient:
PressureMotionMinZ      = format mismatch (32)

I'm not an expert on X11, but XA_CARDINAL seems to be an integer, so
it should be fairly easy to add support. Or to revert back to
"integer" as a hotfix.
Comment 1 Marcus Moeller 2012-04-04 04:35:26 EDT
fixed in xorg-x11-drv-synaptics-1.5.99.901-2

Note You need to log in before you can comment on or make changes to this bug.