Bug 809579 - New snapshot is not created when Entitlements are added to a system via API.
New snapshot is not created when Entitlements are added to a system via API.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
550
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Tomas Lestach
Jiří Mikulka
:
Depends On:
Blocks: sat550-api sat550-lowbug
  Show dependency treegraph
 
Reported: 2012-04-03 12:59 EDT by Dimitar Yordanov
Modified: 2014-10-06 09:46 EDT (History)
5 users (show)

See Also:
Fixed In Version: spacewalk-java-1.7.54-24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 857635 (view as bug list)
Environment:
Last Closed: 2012-09-21 05:20:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dimitar Yordanov 2012-04-03 12:59:41 EDT
Description of problem:
System Snapshots are not created when Entitlements are added to a system via API call system.upgradeEntitlement.

Version-Release number of selected component (if applicable):
Satellite 5.4.1
Spacewalk 1.7

How reproducible:
100%

Steps to Reproduce:
1.Register System to Spacewalk 1.7. 
2.Add Provisioning entitlement to the System.
   Systems -> the System profile -> System Properties (Edit These Properties) -> check Provisioning 
3.Add Monitoring entitlement to the System.
  Systems -> the System profile -> System Properties (Edit These Properties) -> check  Monitoring

4.Systems -> the System profile -> Provisioning -> Snapshots
    There is a new Snapshot due to the changes made in  [2][3]

5. Remove the Monitoring Entitlemnt for the system
    Systems -> the System profile -> System Properties (Edit These Properties) -> uncheck  Monitoring

6. Try to add Monitoring entitlement to the system via API system.upgradeEntitlement.
 
  
Actual results:
When the entitlement is added via API new snapshot is not created under
Systems -> the System profile -> Provisioning -> Snapshots

Expected results:
When the system entitlements are altered via API new snapshot is created.

Additional info:
See: manage-system.py admin admin https://`hostname`/rpc/api UPGRADE_ENTITLEMENT 1000010000 [monitoring_entitled|provisioning_entitled|virtualization_host|virtualization_host_platform]
Comment 1 Dimitar Yordanov 2012-04-05 09:59:33 EDT
Due to this bug /usr/sbin/spacewalk-channel have the same problem.
Comment 2 Dimitar Yordanov 2012-04-05 10:24:29 EDT
Please discard Comment 1.

For all changes made by /usr/sbin/spacewalk-channel new profile snapshot is not created because the following API calls have the same problem as described in "Description".
system.setBaseChannel(string sessionKey, int serverId, string channelLabel) system.setChildChannels(string sessionKey, int serverId, array[string channelLabel])
Comment 4 Tomas Lestach 2012-04-13 11:42:42 EDT
spacewalk.git: ca2274492a75db66e05e99e8a83f3feac7cd5694
Comment 8 Clifford Perry 2012-09-21 05:20:44 EDT
This issue is resolved with the release of RHN Satellite 5.5. 

As of September 20th 2012, RHN Satellite 5.5 has been generally available. 

Release Notes and other 5.5 documentation can be found here:

 https://access.redhat.com/knowledge/docs/Red_Hat_Network_Satellite/

The associated Errata for the 5.5 release are:

5.5 Satellite GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1296.html

5.5 Upgrade Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1298.html

5.5 RHN Proxy GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1297.html

5.5 RHN Tools GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1299.html

Regards,
Clifford
- Engineering Manager, Satellite

Note You need to log in before you can comment on or make changes to this bug.