Bug 809583 - Posix test failures on cifs mount
Posix test failures on cifs mount
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: posix (Show other bugs)
pre-2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Kaushal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-03 13:15 EDT by Ujjwala
Modified: 2015-12-01 11:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 06:32:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test results file (5.34 KB, application/octet-stream)
2012-04-03 13:15 EDT, Ujjwala
no flags Details
test results for backend dir cifs mount (5.34 KB, application/octet-stream)
2012-04-03 13:16 EDT, Ujjwala
no flags Details

  None (edit)
Description Ujjwala 2012-04-03 13:15:14 EDT
Created attachment 574912 [details]
Test results file

Description of problem:
I have run posix tests on cifs mounts - both dir cifs mount (XFS backend) and gluster volume cifs mount
Many of the tests fail on both the mount.
But there are some extra failures on the gluster volume cifs mount in link and mkfifo tests.
Attached is the test result for both mounts.


Version-Release number of selected component (if applicable):
3.3.0 qa31

How reproducible:
Always

Steps to Reproduce:
1. Configure samba and do a cifs mount of a dir and gluster volume
2. Run posix tests on both the mount points.
3. Compare the results
  
Actual results:
Some of link and mkfifo tests that are passing on backend dir is failing on gluster volume 


Expected results:
Number of failures should be same for both mounts

Additional info:
Comment 1 Ujjwala 2012-04-03 13:16:32 EDT
Created attachment 574913 [details]
test results for backend dir cifs mount
Comment 2 Kaushal 2012-04-18 06:32:50 EDT
This is not a gluster bug. 
The extra failed tests are all tests that check times (ctime, atime, mtime) of files. This is caused because of the difference in granularity of timestamps between XFS and Samba. XFS has 1 ns granularity whereas samba uses 100ns granularity.

Since, the posix-compliance testsuite is configured for XFS, there is a possiblity of some time comparision tests to fail as the comparisions are done at a nanosecond level. Though there is a change in the timestamp on the backend XFS, Samba can mask this change because of its larger granularity. This will cause tests like the ones above to fail some of the times. This also means that the same tests may not fail all the time as there is a possiblity of change in timestamp being large enough that even samba will show a change in timestamp.

The solution would be to run a modified version of the test-suite, which has the timestamp comparision tests disabled, on cifs mounts.

Note You need to log in before you can comment on or make changes to this bug.