Bug 809613 - Undefined error when saving state of a VM with USB devices assigned
Undefined error when saving state of a VM with USB devices assigned
Status: CLOSED DUPLICATE of bug 805172
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.2
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-03 15:47 EDT by 6ax
Modified: 2013-04-15 05:16 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-17 09:11:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
As you requested: /var/log/libvirt/qemu/winsrv.log (1.15 KB, text/plain)
2012-04-05 08:57 EDT, 6ax
no flags Details
VM config winsrv.xml (2.11 KB, text/xml)
2012-04-05 09:01 EDT, 6ax
no flags Details

  None (edit)
Description 6ax 2012-04-03 15:47:39 EDT
The command:
   virsh save winsrv testsavefile 
get an error like: QEMU «migrate»: An undefined error has ocurred

if the config file to remove the block containing:

  <hostdev mode='subsystem' type='usb' managed='yes'>
       <source>
         <address bus='2' device='3'/>
       </ source>
     </ hostdev>

and then:
virsh save winsrv testsavefile

saves the file without errors.

libvirt-python-0.9.4-23.el6_2.7.x86_64
libvirt-client-0.9.4-23.el6_2.7.x86_64
libvirt-0.9.4-23.el6_2.7.x86_64
qemu-kvm-0.12.1.2-2.209.el6_2.4.x86_64
Comment 2 Jiri Denemark 2012-04-05 08:40:44 EDT
The unhelpful error message is coming from qemu. I'm not sure it makes any sense to save/restore a domain with host devices assigned (I'm afraid they the devices will be in different internal state when the domain is resumed) but I will reassign this to qemu-kvm for now to check what's going on...

Could you attach /var/log/libvirt/qemu/winsrv.log file, which contains the command line qemu-kvm was started with and hopefully also some more messages from qemu.
Comment 3 6ax 2012-04-05 08:57:01 EDT
Created attachment 575400 [details]
As you requested: /var/log/libvirt/qemu/winsrv.log
Comment 4 6ax 2012-04-05 09:01:39 EDT
Created attachment 575402 [details]
VM config winsrv.xml
Comment 5 Ademar Reis 2012-04-17 09:11:08 EDT
save/restore of domains with assigned devices is not supported. The error message is not friendly, but this is not critical and has been improved on upstream (so RHEL7 will have it right).

Closing bug as deferred because the "undefined error" will be fixed in RHEL7 (although the use case will still be invalid).
Comment 6 Gerd Hoffmann 2013-04-15 05:16:04 EDT

*** This bug has been marked as a duplicate of bug 805172 ***

Note You need to log in before you can comment on or make changes to this bug.