Bug 809663 - RFE: clean up boot menus, and put mediacheck option in the top-level menu, not hidden under "Troubleshooting"
RFE: clean up boot menus, and put mediacheck option in the top-level menu, no...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
: FutureFeature, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-03 20:54 EDT by Andre Robatino
Modified: 2013-07-04 09:02 EDT (History)
9 users (show)

See Also:
Fixed In Version: lorax-18.12-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-02 07:12:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of the RATS1 top level menu (12.93 KB, image/png)
2012-08-02 06:12 EDT, Andre Robatino
no flags Details

  None (edit)
Description Andre Robatino 2012-04-03 20:54:05 EDT
Description of problem:
Mediacheck is no longer a discoverable option when using an install disc (DVD or netinst). There is a 'check' boot option which causes a mediacheck to be done, but it is not included by default in any of the boot menu items. I suggest that the "Install or upgrade Fedora" boot menu option should include 'check' as a boot option so it happens by default. Perhaps an additional menu option (something like "Install or upgrade Fedora without checking media") could be added, but it should not be the default choice. Under the "Troubleshooting" menu, perhaps there should be two options corresponding to "Install Fedora in basic graphics mode", one with and one without mediacheck. Options that don't read much of the disc, such as "Run a memory test." don't need a default mediacheck.

Additional info:
With split media, the mediacheck had to be interactive, since one had to manually swap discs in order to check all of them. With that gone, it's reasonable to do the check automatically without prompting.
Comment 1 Bill Nottingham 2012-04-10 15:42:06 EDT
CC'ing assorted people for opinions.
Comment 2 David Cantrell 2012-04-10 17:20:50 EDT
I have no problem adding a boot entry called "Install Fedora with mediacheck enabled' (probably a better name though).  I don't want mediacheck enabled by default for standard installs because that would annoy me.
Comment 3 Adam Williamson 2012-04-10 17:51:04 EDT
I'm okay with default media check. It's fast on USB sticks and in VMs, it's only slow with actual spinny silver discs, which you *really* do want to verify...

also okay with a menu option, I guess.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Hedayat Vatankhah 2012-04-11 03:00:27 EDT
IMHO: please don't make it default (without any prompts and the ability to skip the test). Consider that you have a DVD. You might would like to check it once, but not every time you want to install from that disc. Also consider if something goes wrong during the installation and you want to start from scratch. You don't want to check your DVD again and spend a long time for it while you've checked it 10 minutes ago. So, please don't make it mandatory (Well, except it another menu entry allows me to run the installer without any media checks).
Comment 5 Andre Robatino 2012-04-11 05:49:48 EDT
"Default" implies "optional" - I never suggested that it be mandatory, and I understand that that would be a bad idea (although personally the only time I would skip the mediacheck is if for some reason I needed to restart an install/upgrade on a given machine, and had already done the mediacheck on it at least once).
Comment 6 Andre Robatino 2012-04-11 14:44:04 EDT
Rereading what I wrote, I didn't say there should definitely be an additional menu item that would skip the mediacheck. But in any case, one could just hit TAB and remove "check" from the boot options, so even without a non-mediacheck menu option, it would still be optional, just not as easy to do. Personally I think the extra menu option is a good idea, for one thing it's more consistent with the live images which have 2 menu options for either doing or not doing the check. (Although for live images, not doing it is the default. This probably makes sense for lives since they're often just used to run live as opposed to installing.)
Comment 7 Andre Robatino 2012-04-28 03:26:49 EDT
I just discovered that when the mediacheck fails, after printing the error it proceeds as if nothing had happened. This is bad since if one isn't looking at the right moment they won't notice that the check failed. It tends to defeat the purpose of making mediacheck the default.
Comment 8 Andre Robatino 2012-04-29 18:14:31 EDT
Filed bug 817419 for the issue of not getting a warning prompt when mediacheck fails. This happens on both Install and Live images (see the thread at https://lists.fedoraproject.org/pipermail/devel/2012-April/166555.html ).
Comment 9 Andre Robatino 2012-05-17 09:37:30 EDT
Bug 817419 has now been fixed. It's a little ugly in that a FAIL basically shuts down the installer rather than ask whether to continue, but one can reboot skipping the mediacheck for that. Also, the install discs now have a mediacheck option identical to that for lives (non-default). This is easier to maintain, but it would be nice if the mediacheck could be done by default when an install is expected - so for installs, when one boots, and for lives, just after clicking on "Install to hard drive" (if that's possible). Of course, in both cases, skipping the mediacheck should be an option (and given the way that a FAIL behaves now, it has to be).
Comment 10 Andre Robatino 2012-05-28 04:47:40 EDT
See my post

suggested changes for install and live boot menus
https://lists.fedoraproject.org/pipermail/devel/2012-May/167466.html

which would include making checking the media the default on install discs (but with the non-checking option right next to it so it's easy to skip). Right now it's hidden under the Troubleshooting menu on both installs and lives.
Comment 11 Andre Robatino 2012-06-02 05:55:02 EDT
Changing component to lorax. In addition to putting mediacheck in the top-level menu, and making it the default on install discs, the inconsistencies that comment 10 would fix are

* Periods at the end of some lines and not others (just get rid of all of them)
* On the install Troubleshooting menu, the basic video option doesn't mention upgrade
Comment 12 Andre Robatino 2012-06-02 05:59:19 EDT
Forgot

* Currently live image menus mention specific Fedora version when applicable, but install images don't - it's probably good to be specific when possible
Comment 13 Martin Gracik 2012-06-04 02:47:03 EDT
I don't _ever_ do a media check, so I don't like it to be default, but OK.
Comment 14 Andre Robatino 2012-08-02 06:05:13 EDT
Noticed that on the 18-RATS1 image, the menu items are exactly what I suggested in https://lists.fedoraproject.org/pipermail/devel/2012-May/167466.html , except that you included the actual WORD "(default)" in the menu items (I was only using it to suggest which item should be the default item). In other words, I meant to suggest

Install top level menu:

Install/upgrade Fedora 18
Test this media & install/upgrade Fedora 18
Troubleshooting

with the second item being the default, and

Live top level menu:

Start Fedora 18
Test this media & start Fedora 18
Troubleshooting

with the first item being the default.
Comment 15 Andre Robatino 2012-08-02 06:12:24 EDT
Created attachment 601916 [details]
screenshot of the RATS1 top level menu

Screenshot attached. Note that in addition to the second item actually being the default, as intended, it also has the WORD "(default)" in its description (which could confuse people).
Comment 16 Martin Gracik 2012-08-02 06:57:59 EDT
I thought the default is helpful to the user, in that he sees, that this is the option that will run by default, not the other, particularly in this case, when the default is the 2nd option, not the 1st.
Comment 17 Andre Robatino 2012-08-02 07:12:36 EDT
OK, so it was intentional. I suppose another option would be to switch the order of the first and second items in the install menu, so the default is on top. But it might be good to just leave it as is for now and see what users say. Closing the bug again.

Note You need to log in before you can comment on or make changes to this bug.