Bug 809727 - sosreport not collecting pagetypeinfo
sosreport not collecting pagetypeinfo
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sos (Show other bugs)
6.1
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Bryn M. Reeves
David Kutálek
:
Depends On:
Blocks: 811045
  Show dependency treegraph
 
Reported: 2012-04-04 04:25 EDT by masanari iida
Modified: 2013-02-21 05:57 EST (History)
5 users (show)

See Also:
Fixed In Version: sos-2.2-32.el6
Doc Type: Bug Fix
Doc Text:
Cause: The pagetypeinfo file contains additional information relevant to external fragmentation of kernel memory. Previous versions of sos only collected the related buddyinfo data. Consequence: Less detailed information is available regarding the fragmentation state of the kernel page allocator. Fix: This file is now included in the generated report. Result: Detailed fragmentation debugging data is now collected by default avoiding manual effort to obtain this information.
Story Points: ---
Clone Of:
: 811045 (view as bug list)
Environment:
Last Closed: 2013-02-21 05:57:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description masanari iida 2012-04-04 04:25:55 EDT
Description of problem:
sosreport on RHEL6.1 not collecting /proc/pagetypeinfo


Version-Release number of selected component (if applicable):
sos-2.2-8.el6.noarch 

How reproducible:
Always

Steps to Reproduce:
1. collect sosreport
2. Extract the archive, and see proc directory.
3. See sos_commands/memory directory.
  
Actual results:
pagetypeinfo file is not exist

Expected results:
pagetypeinfo file is exist

Additional info:
/proc/pagetypeinfo was introduced on RHEL6.
It contain important information about memory fragmentation.
These days, we see more "page allocation failure" cases. 
Collecting pagetypeinfo from the system from affected system is 
required for troubleshooting.

Business impact: None
Importance: Middle
I hope this request is accepted for RHEL6.3 or 6.4.
Comment 2 Bryn M. Reeves 2012-04-04 05:58:48 EDT
Thanks for the report. We're planning to expand both /proc and /sys data collection upstream in the near future. In the past we needed to be a little selective over what we touched here as certain files could be problematic when the system was already in some way compromised. Things are a lot more robust these days although we still need some kind of mechanism.

Anyway, whether this bug gets addresses through that work or as a one-off addition to RHEL6 for now will depend on the progress on that work in the mean time but this is a simple and standalone fix.
Comment 3 Bryn M. Reeves 2012-04-04 05:59:26 EDT
... mechanism for blacklisting certain paths.
Comment 5 RHEL Product and Program Management 2012-05-03 01:40:48 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 10 errata-xmlrpc 2013-02-21 05:57:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0474.html

Note You need to log in before you can comment on or make changes to this bug.