Bug 809737 - SELinux is preventing /usr/bin/python from 'setattr' accesses on the file /etc/dhcp/wireless-settings.conf.
SELinux is preventing /usr/bin/python from 'setattr' accesses on the file /et...
Status: CLOSED DUPLICATE of bug 809736
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:9c59144983cad0aa6137e26ba30...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 04:54 EDT by klement.sekera
Modified: 2012-04-04 05:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-04 05:11:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description klement.sekera 2012-04-04 04:54:55 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-8.fc16.x86_64
reason:         SELinux is preventing /usr/bin/python from 'setattr' accesses on the file /etc/dhcp/wireless-settings.conf.
time:           Wed 04 Apr 2012 10:54:44 AM CEST

description:
:SELinux is preventing /usr/bin/python from 'setattr' accesses on the file /etc/dhcp/wireless-settings.conf.
:
:*****  Plugin catchall_labels (83.8 confidence) suggests  ********************
:
:If you want to allow python to have setattr access on the wireless-settings.conf file
:Then you need to change the label on /etc/dhcp/wireless-settings.conf
:Do
:# semanage fcontext -a -t FILE_TYPE '/etc/dhcp/wireless-settings.conf'
:where FILE_TYPE is one of the following: NetworkManager_var_lib_t, NetworkManager_var_run_t, net_conf_t, pppd_var_run_t, named_cache_t, NetworkManager_etc_rw_t, NetworkManager_tmp_t, NetworkManager_log_t, root_t. 
:Then execute: 
:restorecon -v '/etc/dhcp/wireless-settings.conf'
:
:
:*****  Plugin catchall (17.1 confidence) suggests  ***************************
:
:If you believe that python should be allowed setattr access on the wireless-settings.conf file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep wicd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:NetworkManager_t:s0
:Target Context                unconfined_u:object_r:etc_t:s0
:Target Objects                /etc/dhcp/wireless-settings.conf [ file ]
:Source                        wicd
:Source Path                   /usr/bin/python
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           python-2.7.2-5.2.fc16.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-80.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-8.fc16.x86_64 #1 SMP
:                              Thu Mar 29 18:37:19 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    Wed 04 Apr 2012 10:53:51 AM CEST
:Last Seen                     Wed 04 Apr 2012 10:53:58 AM CEST
:Local ID                      35ba5c92-b330-4f44-92e5-b902ffe42bb7
:
:Raw Audit Messages
:type=AVC msg=audit(1333529638.100:92): avc:  denied  { setattr } for  pid=2737 comm="wicd" name="wireless-settings.conf" dev="sda2" ino=28710 scontext=system_u:system_r:NetworkManager_t:s0 tcontext=unconfined_u:object_r:etc_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1333529638.100:92): arch=x86_64 syscall=chmod success=no exit=EACCES a0=1956f20 a1=180 a2=3ee97b75c8 a3=20 items=0 ppid=1 pid=2737 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=wicd exe=/usr/bin/python subj=system_u:system_r:NetworkManager_t:s0 key=(null)
:
:Hash: wicd,NetworkManager_t,etc_t,file,setattr
:
:audit2allow
:
:#============= NetworkManager_t ==============
:allow NetworkManager_t etc_t:file setattr;
:
:audit2allow -R
:
:#============= NetworkManager_t ==============
:allow NetworkManager_t etc_t:file setattr;
:
Comment 1 Miroslav Grepl 2012-04-04 05:11:24 EDT

*** This bug has been marked as a duplicate of bug 809736 ***

Note You need to log in before you can comment on or make changes to this bug.