Bug 809740 - SELinux is preventing /usr/bin/python from 'unlink' accesses on the file wicd.pid.
SELinux is preventing /usr/bin/python from 'unlink' accesses on the file wicd...
Status: CLOSED DUPLICATE of bug 809736
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:143730b5d22427276d8f2283a2e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 05:04 EDT by klement.sekera
Modified: 2012-04-04 05:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-04 05:11:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description klement.sekera 2012-04-04 05:04:10 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-8.fc16.x86_64
reason:         SELinux is preventing /usr/bin/python from 'unlink' accesses on the file wicd.pid.
time:           Wed 04 Apr 2012 11:04:01 AM CEST

description:
:SELinux is preventing /usr/bin/python from 'unlink' accesses on the file wicd.pid.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that python should be allowed unlink access on the wicd.pid file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep wicd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:NetworkManager_t:s0
:Target Context                unconfined_u:object_r:var_run_t:s0
:Target Objects                wicd.pid [ file ]
:Source                        wicd
:Source Path                   /usr/bin/python
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           python-2.7.2-5.2.fc16.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-80.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-8.fc16.x86_64 #1 SMP
:                              Thu Mar 29 18:37:19 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Wed 04 Apr 2012 11:03:12 AM CEST
:Last Seen                     Wed 04 Apr 2012 11:03:12 AM CEST
:Local ID                      e1ad44be-222a-4012-b678-af5a5e6801cb
:
:Raw Audit Messages
:type=AVC msg=audit(1333530192.394:132): avc:  denied  { unlink } for  pid=3756 comm="wicd" name="wicd.pid" dev="tmpfs" ino=29709 scontext=system_u:system_r:NetworkManager_t:s0 tcontext=unconfined_u:object_r:var_run_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1333530192.394:132): arch=x86_64 syscall=unlink success=no exit=EACCES a0=2811030 a1=1 a2=3ee97b75c8 a3=20 items=0 ppid=1 pid=3756 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=wicd exe=/usr/bin/python subj=system_u:system_r:NetworkManager_t:s0 key=(null)
:
:Hash: wicd,NetworkManager_t,var_run_t,file,unlink
:
:audit2allow
:
:#============= NetworkManager_t ==============
:allow NetworkManager_t var_run_t:file unlink;
:
:audit2allow -R
:
:#============= NetworkManager_t ==============
:allow NetworkManager_t var_run_t:file unlink;
:
Comment 1 Miroslav Grepl 2012-04-04 05:11:33 EDT

*** This bug has been marked as a duplicate of bug 809736 ***

Note You need to log in before you can comment on or make changes to this bug.