Bug 809760 - French - Button names to be translated to French
Summary: French - Button names to be translated to French
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-conductor
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: beta5
Assignee: Tzu-Mainn Chen
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-04 10:22 UTC by Rehana
Modified: 2012-12-04 15:02 UTC (History)
10 users (show)

Fixed In Version: aeolus-conductor-0.13.19-1.el6cf
Doc Type: Bug Fix
Doc Text:
In Cloud Engine (French), some buttons on the cloud provider page were shown in English. This bug fix adds in translation so that the buttons display in the designated language.
Clone Of:
Environment:
Last Closed: 2012-12-04 15:02:45 UTC


Attachments (Terms of Use)
ss1 (216.90 KB, image/png)
2012-04-04 10:22 UTC, Rehana
no flags Details
ss2 (218.93 KB, image/png)
2012-04-04 10:34 UTC, Rehana
no flags Details
b1 (49.27 KB, image/png)
2012-10-17 06:00 UTC, Aziza Karol
no flags Details
b2 (62.54 KB, image/png)
2012-10-17 06:01 UTC, Aziza Karol
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:1516 0 normal SHIPPED_LIVE CloudForms Cloud Engine 1.1 update 2012-12-04 19:51:45 UTC

Description Rehana 2012-04-04 10:22:59 UTC
Created attachment 575078 [details]
ss1

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.enable to french language on browser
2.move to cloud provider page 

  
Actual results:
Observed that the button names like 'save changes' ,'test connection' amd 'delete provider' (PFA:ss1.png)

Expected results:
all these button name is supposed to be translated to French

Additional info:

rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.8.7-1.el6.noarch
aeolus-conductor-doc-0.8.7-1.el6.noarch
aeolus-conductor-daemons-0.8.7-1.el6.noarch
aeolus-configure-2.5.2-1.el6.noarch
aeolus-all-0.8.7-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch

Comment 1 Rehana 2012-04-04 10:33:50 UTC
Observation 2:

labels like none, multiple (while creating application blueprints) needs to be translated to french

PFA: ss2.png, ss3.png

Additional info:

rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.8.7-1.el6.noarch
aeolus-conductor-doc-0.8.7-1.el6.noarch
aeolus-conductor-daemons-0.8.7-1.el6.noarch
aeolus-configure-2.5.2-1.el6.noarch
aeolus-all-0.8.7-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch

Comment 2 Rehana 2012-04-04 10:34:22 UTC
Created attachment 575080 [details]
ss2

Comment 5 Rehana 2012-09-24 13:21:41 UTC
Above mentioned observations are still present on 

rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch

Comment 6 Tzu-Mainn Chen 2012-09-25 15:54:26 UTC
Patch created; leaving this BZ state as ASSIGNED until next round of translations:

http://lists.fedorahosted.org/pipermail/aeolus-devel/2012-September/012691.html

Comment 7 Tzu-Mainn Chen 2012-09-25 20:23:37 UTC
Pushed to master/1.1, still waiting on translation patchset:

commit 55c9034f3bf9347f15462e02e252de614d30c574
Author: Tzu-Mainn Chen <tzumainn@redhat.com>
Date:   Tue Sep 25 11:09:01 2012 -0400

    BZ809760 enforce use of additional translation strings
    (cherry picked from commit 2338c6ee625314be542f1a92c24b91ac8906116f)

Comment 8 Tzu-Mainn Chen 2012-10-15 17:24:21 UTC
Translation patches have been pushed, so this should be fixed now.

Comment 9 Aziza Karol 2012-10-17 05:59:14 UTC
Buttons Translated to french.
see attached screenshot.


verified:
rpm -qa | grep aeolus
aeolus-conductor-doc-0.13.20-1.el6cf.noarch
rubygem-aeolus-cli-0.7.5-1.el6cf.noarch
aeolus-all-0.13.20-1.el6cf.noarch
aeolus-conductor-0.13.20-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-configure-2.8.9-1.el6cf.noarch
aeolus-conductor-daemons-0.13.20-1.el6cf.noarch

Comment 10 Aziza Karol 2012-10-17 06:00:20 UTC
Created attachment 628537 [details]
b1

Comment 11 Aziza Karol 2012-10-17 06:01:15 UTC
Created attachment 628538 [details]
b2

Comment 13 errata-xmlrpc 2012-12-04 15:02:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html


Note You need to log in before you can comment on or make changes to this bug.