Bug 809819 - Features listed when you run --features aren't listed when you run --help
Summary: Features listed when you run --features aren't listed when you run --help
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xmlrpc-c
Version: 6.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 6.5
Assignee: Mikolaj Izdebski
QA Contact: Kaleem
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-04 13:03 UTC by Jenny Severance
Modified: 2013-09-11 09:12 UTC (History)
2 users (show)

Fixed In Version: 1.16.24-1210.1840
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-11 09:12:17 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1254 normal SHIPPED_LIVE xmlrpc-c bug fix update 2013-09-11 13:10:46 UTC

Description Jenny Severance 2012-04-04 13:03:34 UTC
Description of problem:

If there are features listed when you run it with --features which aren't listed when run with --help

<script>
  for feature in "" `xmlrpc-c-config --features` ; do
    for what in cflags libs ldadd ldflags prefix ; do
      xmlrpc-c-config $feature --$what
    done
  done
</script>

# xmlrpc-c-config --features
c++ abyss-server curl-client


script execution ...

-I/usr/include/libxml2  
Must specify package names on the command line
-lxmlrpc_client  

/usr
-I/usr/include/libxml2  
-lxmlrpc_cpp  
-lxmlrpc_cpp  

/usr
-I/usr/include/libxml2  
-lxmlrpc_server_abyss  
-lxmlrpc_server_abyss  

/usr
Unrecognized token 'curl-client'
Unrecognized token 'curl-client'
Unrecognized token 'curl-client'
Unrecognized token 'curl-client'
Unrecognized token 'curl-client'



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install xmlrpc-c-devel
2. xmlrpc-c-config --features
3. execute script above
  
Actual results:


Expected results:


Additional info:

Comment 6 Mikolaj Izdebski 2013-06-25 13:50:41 UTC
Fixed in xmlrpc-c-1.16.24-1210.1840.

Now features listed in --help should be consistent with the list in --features.
Running the reproducer script should't result in any "Unrecognized token" errors.

Comment 8 Namita Soman 2013-09-09 14:20:11 UTC
Verified using:
xmlrpc-c-1.16.24-1210.1840.el6.x86_64

Running the script didn't see any "Unrecognized token" errors. Output is:
# cat testrun.sh 
for feature in "" `xmlrpc-c-config --features` ; do
    for what in cflags libs ldadd ldflags prefix ; do
      xmlrpc-c-config $feature --$what
    done
  done

# ./testrun.sh
-I/usr/include/libxml2  
Must specify package names on the command line
-lxmlrpc_client  
 
/usr
-I/usr/include/libxml2  
-lxmlrpc_server_abyss  
-lxmlrpc_server_abyss  
 
/usr
-I/usr/include/libxml2  
-lxmlrpc_cpp  
-lxmlrpc_cpp  
 
/usr
-I/usr/include/libxml2  
Must specify package names on the command line
-lxmlrpc_client  
 
/usr
-I/usr/include/libxml2  
-lxmlrpc_server_cgi  
-lxmlrpc_server_cgi  
 
/usr
-I/usr/include/libxml2  
-lxmlrpc_client  
-lxmlrpc_client  
 
/usr
-I/usr/include/libxml2  
-lxmlrpc_packetsocket  
-lxmlrpc_packetsocket  
 
/usr
-I/usr/include/libxml2  
-lxmlrpc_server_pstream++  
-lxmlrpc_server_pstream++  
 
/usr
-I/usr/include/libxml2  
-lxmlrpc_server  
-lxmlrpc_server  
 
/usr


Verified --features and --help match:
# xmlrpc-c-config --features
abyss-server c++ c++2 cgi-server client packetsocket pstream-server server-util

# xmlrpc-c-config --help
Usage: xmlrpc-c-config <feature> ... <option> ...

The features are:
  c++            legacy C++ wrapper API
  c++2           modern C++ API
  client         client functions
  cgi-server     CGI-based server functions
  abyss-server   ABYSS-based server functions
  pstream-server pstream-based server functions
  server-util    basic server functions (implied by *-server)
  packetsocket   datagram socket API

Options are:
  --version      The version number of the package
  --features     List all features (aka modules) currently installed
  --cflags       C compiler flags to use when '#include'ing package headers
  --libs         Libraries and flags to use when linking programs normally
  --ldadd        Libraries to use with automake
  --ldflags      Flags to use with automake & libtool
  --prefix       The prefix under which the package was installed

Comment 10 errata-xmlrpc 2013-09-11 09:12:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1254.html


Note You need to log in before you can comment on or make changes to this bug.