Bug 809824 - katello-configure with no deployment option returns unfriendly error.
katello-configure with no deployment option returns unfriendly error.
Status: CLOSED DUPLICATE of bug 809823
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello-configure (Show other bugs)
1.0.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Jordan OMara
SAM QE List
:
Depends On:
Blocks: sam12-tracker
  Show dependency treegraph
 
Reported: 2012-04-04 09:16 EDT by Eric Sammons
Modified: 2014-11-09 17:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
katello-configure-0.1.107-1.el6.noarch
Last Closed: 2012-04-27 16:08:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sammons 2012-04-04 09:16:50 EDT
Description of problem:
When running katello-configure there is no obvious default deployment type; however, rather than explaining that deployment type should be passed a err is returned that is no user friendly.

Version-Release number of selected component (if applicable):
katello-configure-0.1.107-1.el6.noarch

How reproducible:


Steps to Reproduce:
1. yum install -y katello-headpin-all
2. katello-configure

Actual results:
# katello-configure 
Starting Katello configuration
The top-level log file is [/var/log/katello/katello-configure-20120404-091126/main.log]
err: /Stage[main]/Mongodb::Service/Service[mongod]/ensure: change from stopped to running failed: Could not start Service[mongod]: Execution of '/sbin/service mongod start' returned 1:  at /usr/share/katello/install/puppet/modules/mongodb/manifests/service.pp:5
err: /Stage[main]/Certs::Config/Exec[strip-qpid-client-certificate]/returns: change from notrun to 0 failed: cp /root/ssl-build/mgmt9.rhq.lab.eng.bos.redhat.com/qpid-client.key /etc/pki/pulp/qpid_client_striped.crt; openssl x509 -in /root/ssl-build/mgmt9.rhq.lab.eng.bos.redhat.com/qpid-client.crt >> /etc/pki/pulp/qpid_client_striped.crt returned 1 instead of one of [0] at /usr/share/katello/install/puppet/modules/certs/manifests/config.pp:311
err: /File[/var/lib/pulp/packages]/ensure: change from absent to directory failed: Cannot create /var/lib/pulp/packages; parent directory /var/lib/pulp does not exist


Expected results:
Error explaining that a deployment type must be specified.
Comment 2 Jordan OMara 2012-04-27 16:08:28 EDT
Duplicate of 809823; "katello" is the default deployment which is why you get these errors

*** This bug has been marked as a duplicate of bug 809823 ***

Note You need to log in before you can comment on or make changes to this bug.