Bug 809828 - tail -f does not work with GPFS file systems
tail -f does not work with GPFS file systems
Status: CLOSED DUPLICATE of bug 769874
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: coreutils (Show other bugs)
6.2
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Ondrej Vasik
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 09:26 EDT by Joe Pope
Modified: 2012-04-04 09:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-04 09:45:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Pope 2012-04-04 09:26:09 EDT
Description of problem: tail -f does not work on GPFS file systems.


Version-Release number of selected component (if applicable):
coreutils-8.4-16.el6.x86_64

How reproducible: Write to a file on hostA within a GPFS file system and try to run "tail -f filename" on hostB. The "tail -f" command on hostB will not produce any output although the file is being updated. The "tail -f" command does work correctly on hostA.


Steps to Reproduce:
1.write to a file within a GPFS file system on hostA
2.tail -f that file on hostB
3.the tail -f command will not produce output on hostB
  
Actual results: The "tail -f" command on hostB will not produce any output although the file is being updated.

Expected results: The tail -f command should work the same on hostA and hostB


Additional info: Searches concerning this issue point to a missing or incorrect magic number in the tail code for GPFS
Comment 1 Jim Meyering 2012-04-04 09:37:04 EDT
Thanks for the report.
For reference, this was fixed in upstream coreutils-8.15.
Here's the corresponding NEWS entry:

  * Noteworthy changes in release 8.15 (2012-01-06) [stable]
    ...
    tail -f no longer tries to use inotify on GPFS or FhGFS file systems
    [you might say this was introduced in coreutils-7.5, along with inotify
     support, but the new magic numbers weren't in the usual places then.]

Here's the commit:

  http://git.sv.gnu.org/cgit/coreutils.git/commit/?id=d191bfe8a688d40
Comment 3 Ondrej Vasik 2012-04-04 09:45:58 EDT
Already tracked and planned for fix in RHEL-6 ... closing DUPLICATE.

*** This bug has been marked as a duplicate of bug 769874 ***

Note You need to log in before you can comment on or make changes to this bug.