Bug 809836 - SELinux is preventing tuned from 'execute_no_trans' accesses on the file /usr/lib/tuned/balanced/script.sh.
SELinux is preventing tuned from 'execute_no_trans' accesses on the file /usr...
Status: CLOSED DUPLICATE of bug 809832
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:b3bbf1470a29a0b95297690e474...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 09:39 EDT by Karel Volný
Modified: 2012-04-04 19:45 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-04 19:45:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2012-04-04 09:39:04 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-1.fc17.i686
reason:         SELinux is preventing tuned from 'execute_no_trans' accesses on the file /usr/lib/tuned/balanced/script.sh.
time:           Wed 04 Apr 2012 09:38:36 AM EDT

description:
:SELinux is preventing tuned from 'execute_no_trans' accesses on the file /usr/lib/tuned/balanced/script.sh.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that tuned should be allowed execute_no_trans access on the script.sh file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep tuned /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:tuned_t:s0
:Target Context                system_u:object_r:lib_t:s0
:Target Objects                /usr/lib/tuned/balanced/script.sh [ file ]
:Source                        tuned
:Source Path                   tuned
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           tuned-2.0.1-1.fc17.noarch
:Policy RPM                    selinux-policy-3.10.0-110.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-1.fc17.i686 #1
:                              SMP Mon Mar 19 03:19:22 UTC 2012 i686 i686
:Alert Count                   2
:First Seen                    Wed 04 Apr 2012 09:37:08 AM EDT
:Last Seen                     Wed 04 Apr 2012 09:37:25 AM EDT
:Local ID                      19dd8ae7-2fa0-4f9d-a7f5-fb7bf8921d64
:
:Raw Audit Messages
:type=AVC msg=audit(1333546645.113:319): avc:  denied  { execute_no_trans } for  pid=2191 comm="tuned" path="/usr/lib/tuned/balanced/script.sh" dev="dm-0" ino=37954 scontext=system_u:system_r:tuned_t:s0 tcontext=system_u:object_r:lib_t:s0 tclass=file
:
:
:Hash: tuned,tuned_t,lib_t,file,execute_no_trans
:
:audit2allow
:
:#============= tuned_t ==============
:allow tuned_t lib_t:file execute_no_trans;
:
:audit2allow -R
:
:#============= tuned_t ==============
:allow tuned_t lib_t:file execute_no_trans;
:
Comment 1 Karel Volný 2012-04-04 10:01:19 EDT
CCing tuned maintainer, and jscotka & jskarvad as this is from PM testday
Comment 2 Michal Ambroz 2012-04-04 18:19:56 EDT
same issue found as part of the pm testing day.
Comment 3 Michal Ambroz 2012-04-04 19:45:05 EDT
Should be probably solved together with other events triggered by 
"tuned-adm profile something".

Marking as duplicate of 809832.

*** This bug has been marked as a duplicate of bug 809832 ***

Note You need to log in before you can comment on or make changes to this bug.