Bug 809868 - Status of Events scheduled by Taskomatic not present under Schedule - Failed Actions tab
Status of Events scheduled by Taskomatic not present under Schedule - Failed ...
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
1.8
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Stephen Herr
Red Hat Satellite QA List
:
Depends On: 695676 825377
Blocks: space18
  Show dependency treegraph
 
Reported: 2012-04-04 10:32 EDT by Stephen Herr
Modified: 2012-11-01 12:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 695676
Environment:
Last Closed: 2012-11-01 12:19:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Herr 2012-04-04 10:32:19 EDT
+++ This bug was initially created as a clone of Bug #695676 +++

Description of problem:
Events which are triggered by taskomatic are not visible under Schedule -> Failed Actions tab.

Example: Events like "Show differences between profiled config files and deployed config files)" which are scheduled by taskomatic.

Version-Release number of selected component (if applicable):
RHN Satellite v5.4.0

How reproducible:
Always

Steps to Reproduce:
1. Subscribe a system to config channel and ensure diff is not enabled on that system
2. Let taskomatic schedule the config files diff
3. Check systems -> events and Schedule -> Failed Actions
  
Actual results:
1] Event failure (due to lack of permissions) is seen under that system -> events -> history tab but those events are not visible under Schedule -> Failed Actions.
2] These failed events are also present in the daily summary email
Completed Failed
Package Install 2 0
Schedule a package sync for kickstarts 2 0
Show differences between profiled config files and deployed config files 33 3

Expected results:
1] These events should also be displayed under Failed Actions tab as it is easy to check for which system it failed.

Additional info:
This happens also for taskomatic scheduled events
Comment 1 Stephen Herr 2012-04-04 10:33:56 EDT
Upon investigation, it appears that automatically-scheduled tasks are listed in the Pending and Completed tabs, but not in the Failed and Archived tabs. I will fix so that they are listed everywhere.
Comment 2 Stephen Herr 2012-04-04 10:36:59 EDT
Committed to Spacewalk master: ee785ba386efac238bf2848f222369337623f332
Comment 4 Jan Pazdziora 2012-10-30 15:23:56 EDT
Moving ON_QA. Packages that address this bugzilla should now be available in yum repos at http://yum.spacewalkproject.org/nightly/
Comment 5 Jan Pazdziora 2012-11-01 12:19:11 EDT
Spacewalk 1.8 has been released: https://fedorahosted.org/spacewalk/wiki/ReleaseNotes18

Note You need to log in before you can comment on or make changes to this bug.