Bug 809934 - powertop2tuned parser fails
powertop2tuned parser fails
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: tuned (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Vcelak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 13:07 EDT by Jaroslav Škarvada
Modified: 2013-03-03 20:30 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-17 05:45:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
reproducer (33.77 KB, text/html)
2012-04-04 13:10 EDT, Jaroslav Škarvada
no flags Details

  None (edit)
Description Jaroslav Škarvada 2012-04-04 13:07:52 EDT
Description of problem:
powertop2tuned parser failure.

Version-Release number of selected component (if applicable):
tuned-2.0.1

How reproducible:
Always on affected hardware (Apple).

Steps to Reproduce:
1. powertop2tuned -i powertop.html test
  
Actual results:
It fails.

Expected results:
It shouldn't fail.

Additional info:
Traceback (most recent call last):
  File "/bin/powertop2tuned", line 218, in <module>
    sys.exit(p.generate(new_profile))
  File "/bin/powertop2tuned", line 173, in generate
    profile = self.currentActiveProfile()
  File "/bin/powertop2tuned", line 102, in currentActiveProfile
    proc = Popen(["tuned-adm", "active"], stdout=PIPE)
  File "/usr/lib/python2.7/subprocess.py", line 679, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/subprocess.py", line 1228, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory
Comment 1 Jaroslav Škarvada 2012-04-04 13:10:25 EDT
Created attachment 575185 [details]
reproducer
Comment 2 Jan Kaluža 2012-04-05 02:48:04 EDT
I think tuned-adm wasn't in PATH. Not saying it should show traceback in that case, but it's not bug with parsing.
Comment 3 Jaroslav Škarvada 2012-04-05 04:11:30 EDT
It worked fine now on my devel laptop. I really don't know why it failed on Apple when booted from the same LiveUSB as approx. 20 people did before without any problem. Thus we saved the powertop.html and retried on other f17 installed computer with the reproducer from comment 0 (unfortunately we didn't compare the backtraces). I will retry tomorrow on the f17 installed computer (where it failed) and let you know. I will also try to find contact and CC the person with Apple to retry and provide the backtrace.
Comment 4 Jaroslav Škarvada 2012-04-06 05:17:30 EDT
Got the problem, the powertop2tuned is in utils subpackage that is not required by base package, thus on the affacted machine, the base package was not installed. For now I fixed the requirements upstream. We could also move the powertop2tuned to base package but I think it better fits to utils subpackage.

There was probably another problem that was encountered by the person with Apple, because all packages were pre-installed on the image he used, so I am still trying to contact him.
Comment 5 Jaroslav Škarvada 2012-04-06 09:26:56 EDT
Originally affected machine: MacBook Air 2010, booted from Fedora 17 PM Test Day Live CD. Waiting for response from reporter.
Comment 6 Jaroslav Škarvada 2012-04-17 05:45:17 EDT
Contacted original reporter and the problem is not reproducible anymore, thus closing.

Note You need to log in before you can comment on or make changes to this bug.