Bug 810003 - Kernel panic after using webcam
Kernel panic after using webcam
Status: CLOSED DUPLICATE of bug 806433
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 16:47 EDT by Konstantin Svist
Modified: 2012-04-04 17:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-04 17:00:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Konstantin Svist 2012-04-04 16:47:25 EDT
Description of problem:

As soon as I stop using my webcam, I get the kernel panic below
This has been happening with kernel builds 3.3-*


Version-Release number of selected component (if applicable):
3.3.0-8.fc16.i686

How reproducible:
Frequent, almost every time


Steps to Reproduce:
1. Open Firefox, go to a webcam chat website, e.g. chatroulette or omegle, start a session. (note: Adobe Flash is a prerequisite for this method, don't know if there is any other way to reproduce the behavior)
2. At some point after video is working, close browser window/tab
  
Actual results:
kernel panic

Expected results:
browser window/tab closes normally, there's no user-visible error

Additional info:

[13535.035073] usb 1-3: new high-speed USB device number 2 using ehci_hcd
[13535.165568] usb 1-3: New USB device found, idVendor=045e, idProduct=076d
[13535.165576] usb 1-3: New USB device strings: Mfr=1, Product=2,
SerialNumber=0
[13535.165583] usb 1-3: Product: Microsoft\xffffffc2\xffffffae\xffffffae
LifeCam HD-5000
[13535.165588] usb 1-3: Manufacturer: Microsoft
[13535.374365] Linux media interface: v0.10
[13535.385083] Linux video capture interface: v2.00
[13536.504215] ALSA sound/usb/clock.c:236 2:3:1: cannot get freq at ep 0x82
[13536.505760] ALSA sound/usb/mixer.c:846 5:2: cannot get min/max values for
control 2 (id 5)
[13536.506651] usbcore: registered new interface driver snd-usb-audio
[13536.507627] uvcvideo: Found UVC 1.00 device
Microsoft\xffffffc2\xffffffae\xffffffae LifeCam HD-5000 (045e:076d)
[13536.514088] input: Microsoft\xffffffc2\xffffffae\xffffffae LifeCam HD-5000
as /devices/pci0000:00/0000:00:1d.7/usb1/1-3/1-3:1.0/input/input9
[13536.515392] usbcore: registered new interface driver uvcvideo
[13536.515399] USB Video Class driver (1.1.1)
[13537.755220] ALSA sound/usb/clock.c:236 2:3:1: cannot get freq at ep 0x82
[13538.883229] ALSA sound/usb/clock.c:236 2:3:1: cannot get freq at ep 0x82
[13974.573067] ALSA sound/core/pcm_lib.c:1852 capture write error (DMA or IRQ
trouble?)
[13997.908201] BUG: unable to handle kernel NULL pointer dereference at
0000017c
[13997.909015] IP: [<f815b863>] uvc_video_clock_update+0x63/0x4f0 [uvcvideo]
[13997.909015] *pde = 02479067 *pte = 00000000 
[13997.909015] Oops: 0000 [#1] SMP 
[13997.909015] Modules linked in: uvcvideo videobuf2_core videodev
snd_usb_audio media snd_usbmidi_lib videobuf2_vmalloc videobuf2_memops
snd_rawmidi nf_conntrack_ipv4 nf_defrag_ipv4 rfcomm ppdev parport_pc lp parport
fuse arc4 dell_wmi sparse_keymap bnep bluetooth lockd dell_laptop ip6t_REJECT
nf_conntrack_ipv6 nf_defrag_ipv6 dcdbas ip6table_filter ip6_tables xt_state
nf_conntrack coretemp joydev r852 microcode sm_common nand nand_ids r592
i2c_i801 memstick mtd nand_ecc snd_hda_codec_idt snd_hda_intel snd_hda_codec
snd_hwdep b44 ssb mii snd_seq snd_seq_device snd_pcm iwl4965 iwlegacy mac80211
binfmt_misc iTCO_wdt iTCO_vendor_support snd_timer snd soundcore cfg80211
rfkill snd_page_alloc vhost_net macvtap macvlan tun kvm_intel kvm uinput sunrpc
sdhci_pci sdhci firewire_ohci firewire_core crc_itu_t mmc_core wmi video radeon
ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: nf_defrag_ipv4]
[13997.909015] 
[13997.909015] Pid: 7828, comm: plugin-containe Not tainted 3.3.0-8.fc16.i686
#1 Dell Inc. MM061                           /0XD720
[13997.909015] EIP: 0060:[<f815b863>] EFLAGS: 00010046 CPU: 0
[13997.909015] EIP is at uvc_video_clock_update+0x63/0x4f0 [uvcvideo]
[13997.909015] EAX: 00000000 EBX: 00000000 ECX: 0000017c EDX: 00000012
[13997.909015] ESI: 3b237b67 EDI: eebc1800 EBP: c6d8dd40 ESP: c6d8dc90
[13997.909015]  DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
[13997.909015] Process plugin-containe (pid: 7828, ti=c6d8c000 task=c6bb3240
task.ti=c6d8c000)
[13997.909015] Stack:
[13997.909015]  01ad3ada 00000000 0056a8a9 00000000 0000011c f4807244 f4807244
00000082
[13997.909015]  00000000 c6bb3240 c6d8dccc c046da23 00d0e41f f4807200 463ecd3b
00000cb9
[13997.909015]  c6d8dccc c6d8dcec c0464e50 2f546161 f4802cb8 f4802e40 c27cdea0
f4802cb8
[13997.909015] Call Trace:
[13997.909015]  [<c046da23>] ? trigger_load_balance+0x53/0x260
[13997.909015]  [<c0464e50>] ? scheduler_tick+0xd0/0x100
[13997.909015]  [<c0656b88>] ? timerqueue_add+0x58/0xb0
[13997.909015]  [<f8157a0d>] uvc_buffer_finish+0x1d/0x30 [uvcvideo]
[13997.909015]  [<f8110597>] vb2_dqbuf+0x207/0x370 [videobuf2_core]
[13997.909015]  [<f810ffd6>] ? vb2_qbuf+0x186/0x260 [videobuf2_core]
[13997.909015]  [<c092ce29>] ? __schedule+0x379/0x780
[13997.909015]  [<c0409758>] ? sched_clock+0x8/0x10
[13997.909015]  [<f8157d0c>] uvc_dequeue_buffer+0x3c/0x60 [uvcvideo]
[13997.909015]  [<f81592f6>] uvc_v4l2_do_ioctl+0x8f6/0x1100 [uvcvideo]
[13997.909015]  [<c0926c9e>] ? clear_nohz_tick_stopped.part.8+0x10/0x2b
[13997.909015]  [<c046da98>] ? trigger_load_balance+0xc8/0x260
[13997.909015]  [<c0445611>] ? mod_timer+0x1a1/0x280
[13997.909015]  [<c065b162>] ? _copy_from_user+0x42/0x60
[13997.909015]  [<c0445611>] ? mod_timer+0x1a1/0x280
[13997.909015]  [<f812a159>] video_usercopy+0x1c9/0x500 [videodev]
[13997.909015]  [<f8158a00>] ? uvc_v4l2_open+0x110/0x110 [uvcvideo]
[13997.909015]  [<c06028ab>] ? inode_has_perm+0x3b/0x50
[13997.909015]  [<f8158175>] uvc_v4l2_ioctl+0x25/0x60 [uvcvideo]
[13997.909015]  [<f8158a00>] ? uvc_v4l2_open+0x110/0x110 [uvcvideo]
[13997.909015]  [<f8129343>] v4l2_ioctl+0x93/0x110 [videodev]
[13997.909015]  [<c0445611>] ? mod_timer+0x1a1/0x280
[13997.909015]  [<f81292b0>] ? v4l2_mmap+0xa0/0xa0 [videodev]
[13997.909015]  [<c0544962>] do_vfs_ioctl+0x82/0x5a0
[13997.909015]  [<c0605b57>] ? selinux_file_ioctl+0x47/0xe0
[13997.909015]  [<c0544eef>] sys_ioctl+0x6f/0x80
[13997.909015]  [<c092e4d4>] syscall_call+0x7/0xb
[13997.909015]  [<c0445611>] ? mod_timer+0x1a1/0x280
[13997.909015]  [<c092007b>] ? native_cpu_up+0x1bf/0x92e
[13997.909015]  [<c0920000>] ? native_cpu_up+0x144/0x92e
[13997.909015] Code: 02 00 00 8b 87 a0 03 00 00 8b 9f 9c 03 00 00 8b b6 7c 02
00 00 8d 14 80 83 e8 01 8d 14 93 89 55 d4 31 d2 f7 f1 8b 4d d4 89 75 d0 <8b> 09
8d 04 92 8d 04 83 89 45 cc 89 f0 05 00 00 00 80 29 c1 89 
[13997.909015] EIP: [<f815b863>] uvc_video_clock_update+0x63/0x4f0 [uvcvideo]
SS:ESP 0068:c6d8dc90
[13997.909015] CR2: 000000000000017c
[13997.909015] ---[ end trace cc5a2060742defa4 ]---
[13998.093399] type=1400 audit(1333523025.628:5): avc:  denied  { open } for 
pid=780 comm=72733A6D61696E20513A526567 name="0" dev="devpts" ino=3
scontext=system_u:system_r:syslogd_t:s0
tcontext=unconfined_u:object_r:user_devpts_t:s0 tclass=chr_file
Comment 1 Josh Boyer 2012-04-04 17:00:49 EDT

*** This bug has been marked as a duplicate of bug 806433 ***

Note You need to log in before you can comment on or make changes to this bug.