Bug 810021 - SELinux is preventing /usr/bin/bash from 'module_request' accesses on the system .
SELinux is preventing /usr/bin/bash from 'module_request' accesses on the sys...
Status: CLOSED DUPLICATE of bug 809832
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:55e9ed32f2726f71af88f4bfac6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 18:33 EDT by Michal Ambroz
Modified: 2012-04-04 19:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-04 19:45:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Ambroz 2012-04-04 18:33:33 EDT
libreport version: 2.0.10
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-8.fc17.x86_64
time:           Thu 05 Apr 2012 12:33:07 AM CEST

description:
:SELinux is preventing /usr/bin/bash from 'module_request' accesses on the system .
:
:*****  Plugin catchall_boolean (89.3 confidence) suggests  *******************
:
:If you want to allow all domains to have the kernel load modules
:Then you must tell SELinux about this by enabling the 'domain_kernel_load_modules'boolean.
:Do
:setsebool -P domain_kernel_load_modules 1
:
:*****  Plugin catchall (11.6 confidence) suggests  ***************************
:
:If you believe that bash should be allowed module_request access on the  system by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep script.sh /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:tuned_t:s0
:Target Context                system_u:system_r:kernel_t:s0
:Target Objects                 [ system ]
:Source                        script.sh
:Source Path                   /usr/bin/bash
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           bash-4.2.24-1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-110.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-8.fc17.x86_64 #1 SMP
:                              Thu Mar 29 18:18:26 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Thu 05 Apr 2012 12:32:11 AM CEST
:Last Seen                     Thu 05 Apr 2012 12:32:11 AM CEST
:Local ID                      4ece548b-1cff-46c1-9cb1-d56042981d49
:
:Raw Audit Messages
:type=AVC msg=audit(1333578731.507:1093): avc:  denied  { module_request } for  pid=11718 comm="script.sh" kmod=6E6F6F7020646561646C696E65205B2D696F7363686564 scontext=system_u:system_r:tuned_t:s0 tcontext=system_u:system_r:kernel_t:s0 tclass=system
:
:
:type=SYSCALL msg=audit(1333578731.507:1093): arch=x86_64 syscall=write success=no exit=EINVAL a0=1 a1=7f9dee932000 a2=15 a3=4bb3f2 items=0 ppid=10725 pid=11718 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=script.sh exe=/usr/bin/bash subj=system_u:system_r:tuned_t:s0 key=(null)
:
:Hash: script.sh,tuned_t,kernel_t,system,module_request
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Michal Ambroz 2012-04-04 19:45:53 EDT
Should be probably solved together with other events triggered by 
"tuned-adm profile something".

Marking as duplicate of 809832.

*** This bug has been marked as a duplicate of bug 809832 ***

Note You need to log in before you can comment on or make changes to this bug.