Bug 810027 - SELinux is preventing /usr/bin/df from 'getattr' accesses on the filesystem /mnt/dat1.
SELinux is preventing /usr/bin/df from 'getattr' accesses on the filesystem /...
Status: CLOSED DUPLICATE of bug 809832
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:90a401142152fcef904e610aac2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 19:07 EDT by Michal Ambroz
Modified: 2012-04-04 19:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-04 19:54:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Ambroz 2012-04-04 19:07:11 EDT
libreport version: 2.0.10
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-8.fc17.x86_64
time:           Thu 05 Apr 2012 01:06:38 AM CEST

description:
:SELinux is preventing /usr/bin/df from 'getattr' accesses on the filesystem /mnt/dat1.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that df should be allowed getattr access on the dat1 filesystem by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep df /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:tuned_t:s0
:Target Context                system_u:object_r:fs_t:s0
:Target Objects                /mnt/dat1 [ filesystem ]
:Source                        df
:Source Path                   /usr/bin/df
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           coreutils-8.15-6.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-110.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-8.fc17.x86_64 #1 SMP
:                              Thu Mar 29 18:18:26 UTC 2012 x86_64 x86_64
:Alert Count                   3
:First Seen                    Thu 05 Apr 2012 01:05:21 AM CEST
:Last Seen                     Thu 05 Apr 2012 01:05:21 AM CEST
:Local ID                      6f689322-9994-475c-a975-b8df977f159a
:
:Raw Audit Messages
:type=AVC msg=audit(1333580721.29:1358): avc:  denied  { getattr } for  pid=13357 comm="df" name="/" dev="dm-5" ino=2 scontext=system_u:system_r:tuned_t:s0 tcontext=system_u:object_r:fs_t:s0 tclass=filesystem
:
:
:type=SYSCALL msg=audit(1333580721.29:1358): arch=x86_64 syscall=statfs success=no exit=EACCES a0=6237d0 a1=7fff927aec50 a2=7fff927aed50 a3=38d8377336 items=0 ppid=13356 pid=13357 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=df exe=/usr/bin/df subj=system_u:system_r:tuned_t:s0 key=(null)
:
:Hash: df,tuned_t,fs_t,filesystem,getattr
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Michal Ambroz 2012-04-04 19:54:05 EDT
Should be probably solved together with other events triggered by 
"tuned-adm profile something".

Marking as duplicate of 809832.

*** This bug has been marked as a duplicate of bug 809832 ***

Note You need to log in before you can comment on or make changes to this bug.