Bug 810029 - SELinux is preventing /usr/bin/df from 'open' accesses on the directory /boot.
SELinux is preventing /usr/bin/df from 'open' accesses on the directory /boot.
Status: CLOSED DUPLICATE of bug 809832
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:01d5ccdab2d2c13c9141850e585...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 19:19 EDT by Michal Ambroz
Modified: 2012-04-04 19:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-04 19:50:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Ambroz 2012-04-04 19:19:54 EDT
libreport version: 2.0.10
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-8.fc17.x86_64
time:           Thu 05 Apr 2012 01:19:35 AM CEST

description:
:SELinux is preventing /usr/bin/df from 'open' accesses on the directory /boot.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that df should be allowed open access on the boot directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep df /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:tuned_t:s0
:Target Context                system_u:object_r:boot_t:s0
:Target Objects                /boot [ dir ]
:Source                        df
:Source Path                   /usr/bin/df
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           coreutils-8.15-6.fc17.x86_64
:Target RPM Packages           filesystem-3-2.fc17.x86_64
:Policy RPM                    selinux-policy-3.10.0-110.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-8.fc17.x86_64 #1 SMP
:                              Thu Mar 29 18:18:26 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Thu 05 Apr 2012 01:19:14 AM CEST
:Last Seen                     Thu 05 Apr 2012 01:19:14 AM CEST
:Local ID                      66d63e2b-be1b-4a35-8b0a-685769ced596
:
:Raw Audit Messages
:type=AVC msg=audit(1333581554.119:1456): avc:  denied  { open } for  pid=14278 comm="df" name="/" dev="sda2" ino=2 scontext=system_u:system_r:tuned_t:s0 tcontext=system_u:object_r:boot_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1333581554.119:1456): arch=x86_64 syscall=open success=no exit=EACCES a0=7fff22aa7f41 a1=100 a2=258c030 a3=90 items=0 ppid=14277 pid=14278 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=df exe=/usr/bin/df subj=system_u:system_r:tuned_t:s0 key=(null)
:
:Hash: df,tuned_t,boot_t,dir,open
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Michal Ambroz 2012-04-04 19:50:38 EDT
Should be probably solved together with other events triggered by 
"tuned-adm profile something".

Marking as duplicate of 809832.
Comment 2 Michal Ambroz 2012-04-04 19:50:57 EDT

*** This bug has been marked as a duplicate of bug 809832 ***

Note You need to log in before you can comment on or make changes to this bug.